Exchange 2010 Active Sync Autodiscover not working

Easycom_Admin
Easycom_Admin used Ask the Experts™
on
Hi,

I have setup a hosted exchange 2010 sp1 server. Outlook autodiscover is working fine (also comes up ok in RCA).
However, Exchange ActiveSync autodiscover is not working. When I run the test in RCA (https://www.testexchangeconnectivity.com) I end up with the following error:


Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
Test Steps
ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.mycompany.com/Autodiscover/Autodiscover.xml for user info@mycompany.com
ExRCA failed to obtain an Autodiscover XML response.
Additional Details
None of the expected XML elements were found in the XML response

I have found several threads but none with a solution.
Any help is appreciated.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
After further research I found the following:

From the Exchange Shell run:
 Get-WebServicesVirtualDirectory | FL InternalURL, ExternalURL
 Set-WebServicesVirtualDirectory -Identity -InternalURL – ExternalURL
--------------------------------------------------------------------------------
Get-ActivesyncVirtualDirectory | FL InternalURL, ExternalURL
 Set-ActiveSyncVirtualDirectory -Identity “ServerMicrosoft-Server-ActiveSync (Default Web Site)” -ExternalUrl https://servername.domain.com/Microsoft-Server-ActiveSync
 The Identity parameter uniquely identifies the Exchange ActiveSync virtual directory to be configured. This value must be websiteMicrosoft-Server-ActiveSync (Default Web Site).
 The ExternalUrl parameter specifies the URL used to connect to the virtual directory from outside the network firewall.
--------------------------------------------------------------------------------
Get-AutoDiscoverVirtualDirectory | FL InternalURL, ExternalURL
 Set-AutoDiscoverVirtualDirectory -Identity “ServerAutodiscover (Default Web Site)” -InternalURL https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml
 -ExternalUrl https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml
 From: http://marcskb.wikispaces.com/None+of+the+expected+XML+elements+were+found+in+the+XML+response


now activesync autodiscover RCA is ok as well

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial