Avatar of eugeneca
eugeneca
 asked on

Login as oracle problem

Prepare for installation of Oracle 11g R2 on SUSE Linux Enterprise Server 11 R2.   First created the user: oracle and its password.  Now create a new session, and login as oracle, the error message states:

xsession: login for oracle is disabled.

What was wrong here?



Thanks to help
Linux DistributionsOracle Database

Avatar of undefined
Last Comment
Docteur_Z

8/22/2022 - Mon
David VanZandt

xsession is related to the x-server, so it sounds like this isn't an Oracle question yet.  Try connecting a terminal session directly on the database server as root, and then sudo to oracle.  Oracle should be an O/S account, and described in full detail in the Oracle RDBMS installation notes.
farzanj

If it has to login with /bin/bash, make sure that it (/bin/bash) is present in /etc/shells

vi /etc/shells

/bin/bash
....

Make sure that password is not locked in anyway and user oracle has a shell.  Examine /etc/passwd and /etc/shadow files.
eugeneca

ASKER
The Whole Story:

I am preparing for installation of Oracle 11g R2 on SUSE Linux Enterprise Server 11 R2. First I logged in as root, then created a user named oracle (with its password). Next I tried to switch to user oracle:

#su - oracle

Supposedly I am now oracle user. But when I check the current user for the session, it is still the root, not oracle.

I tested:

echo $USER
or
last | grep $USER
or
env | grep -i user

They all returned: root

Why so?


Now start a new session, and login as oracle, the error message states:

xsession: login for oracle is disabled.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
SOLUTION
farzanj

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
eugeneca

ASKER
#vi /etc/shells
RETURNED: /bin/bash

#su - oracle
RETURNED: blank line (no error message)

#whoami
RETURNED: root

#grep  oracle /etc/passwd
RETURNED:  oracle:x:104:107:Oracle user:/opt/oracle:/bin/false

#grep  oracle /etc/shadow
RETURNED:  oracle:$2y$10$7POSd1HGFeu0Yy5GwJx6EegVlwkSmeTNIS2bYdRChxL.pz84jTYDC:15520:0:99999:7:::

#grep  oracle /etc/shells
RETURNED:  
/bin/bash
/bin/bash1
/usr/bin/bash


Looks like the /bin/false blocked the access.
Docteur_Z

How did you create the account, to have it got /bin/false as shell ?
eugeneca

ASKER
# /usr/bin/useradd  -u 502 -g pinstall -G dba  oracle
#passwd oracle
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.