Avatar of LZ1
LZ1
Flag for United States of America asked on

Wordpress has index.php in URL on hosted Windows install

Hey Experts!!

I have a client who installed WP on ReadyHosting's Windows server plan. The problem I'm having is that if you go to the domain it throws, index.php into the URL. (example:http://mydomain.com/index.php = Home page).  After I make the permalinks correct(/%postname%/), the site just dies.

I've read everywhere that if you have access to install scripts you can download a filter to re-write.  However, I don't have access to the server to do that and I've searched Google up and down and I can't find anything that will help.

So let's assume I can't move to a Linux server and I don't have access to install any additional scripts.  What can I DO???
WordPressWindows Server 2003Microsoft IIS Web Server

Avatar of undefined
Last Comment
Jason C. Levine

8/22/2022 - Mon
SOLUTION
Jaroslav Mraz

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
LZ1

ASKER
I was really trying to avoid using support. Simply because it's time consuming and it's not my account.

There's nothing else I can do?
Jaroslav Mraz

Without rewrite mod you can just use default withou seo version of links index.php=P .....
LZ1

ASKER
Obviously, that's not ideal.  I did tell my client that he should have hosted it on Linux.  Do you know if ReadyHosting can switch something like that on the fly?  I know Godaddy can and you won't lose your site.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Jason C. Levine

You need to add /index.php/ into your permalink and that can sometimes "fix" IIS rewrites without any additional scripting.

So your permalink would be:

/index.php/%postname%/
LZ1

ASKER
Thanks Jason. That's actually how it currently is:
/index.php/%category%/%postname%/

Still no love
ASKER CERTIFIED SOLUTION
Jason C. Levine

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.