Avatar of Todd MacPherson
Todd MacPherson
Flag for Canada asked on

Network Printer prints test page and notepad documents but nothing elese on one PC. Works perfect on rest. Why?

I have 6 computers that connect wirelessly to a network printer that is hardwired to my router. I have 1 Win 98, 1 Win XP Pro, 2 Win Vistas, and 3 Win 7 Home Premium.

All have latest updates installed.

5 of the 6 work perfect. The 6th, a Win 7 Home Premium, is giving me grief. I swapped out the hard drive recently and restored the system to pre-hard drive failure. Everything works but the printer.

I can print the test page and notepad documents but no other application will print to it. Like I said I have a wireless connection.

So before posting here I tried the advice in question https://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_27265589.html but it does not work.

I have tried everything that I can think of and nothing is working. The printer is HP Color LaserJet CP2025DN and uses HP Color LaserJet CP2020 Series PCL6 as the driver. It has the latest driver installed. In the past I just selected install a network printer, selected from the list, and it installed. I have no idea why it won't now.

Any ideas?

Thanks

PBLack
Printers and ScannersComponentsWireless Networking

Avatar of undefined
Last Comment
John

8/22/2022 - Mon
John

Try the following for the affected Windows 7 computer.

1. Remove the printer and also remove the printer driver (Print Server Properties).
2. Click on Devices and Printers, Add a Printer, Local Printer, Next and see the Windows Update Button beside Have Disk. Click on Update and allow to complete.
3. Exit out and restart the computer.
4. Now try to add the printer and see if you can use the Windows 7 HP Universal HP PCL5 driver instead. I am wondering if the PCL5 driver may work here.

.... Thinkpads_User
Todd MacPherson

ASKER
Based on the link in my question I did remove the printer then ran

net stop spooler
net start spooler

Windows Home Premium does not have Print Management so I used the following command in Start::

printui /s /t2

I was able to delete the printer but it would not allow me to delete the .inf file. Said Access denied, even though I am the Admin.

I then tried what you said, a local printer, but had to create a TCP/IP port to the printer. Unfortunately Windows 7 HP Universal HP PCL5 driver is not available as a choice and documentation on the HP site says to use PCL6.

I am still stuck :(
John

Can you try the following:

Temporarily hook up the printer directly to the affected computer. Can you install the driver this way?  If so, turn off the computer, disconnect the printer, hook it back up to your network and then on the affected computer, re-point the printer to the network TCP/IP port.

.... Thinkpads_User
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Todd MacPherson

ASKER
Hi again

I did what you said. At first I could not install directly but once I removed the driver and then reinstalled I got the computer working when directly attached.

I put the printer back on the network and installed it as a local printer and created a new TC/IP port to it. Same problem as before. I can print test page and notepad documents but nothing else.

I wiped it out again then reinstalled it as a network printer and let the wizard do the work. Same result...I can print a test page and notepad documents but nothing else.

I don't know what else to do at this point.

PBLack
ASKER CERTIFIED SOLUTION
John

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Todd MacPherson

ASKER
Hi again

I think the wireless adapter itself has gone buggy. The device is sporadically losing its connection to the network. I will purchase a new one and that should solve the problem.

Thanks for the help.
John

Thank you. I was pleased to assist and good luck with a new adapter.

.... Thinkpads_User
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.