Link to home
Start Free TrialLog in
Avatar of coyotejeff
coyotejeff

asked on

Exchange 2010 SP2 and Outlook 2011

All,

I have a problem where my mac clients using Outlook 2011 cannot send attachments over 2 Meg. The error received is -18500.  I have tried several fixes related to the web.config file in the EWS directory.  The relevant lines we currently have are listed.

<requestLimits maxAllowedContentLength="35000000"/>

<httpRuntime maxRequestLength="2097151" />

All the articles I have come across say the maxRequestLenth should be in kb, however mine appears to be in bytes.  I have adjusted these values in several ways, I will use this link as an example of one of my attempts.  I really have to be missing something simple, Outlook can't be that hard to get to work with macs.  All Exchange servers are running on Server 2008 R2, and Exchange 2010 Sp2

https://edmckinzie.wordpress.com/2009/11/30/max-message-size-increase-owa-imap-ews-maxrequestlength-and-maxallowedcontentlength/


Thank you.
SOLUTION
Avatar of gaurav05
gaurav05
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of coyotejeff
coyotejeff

ASKER

gaurav05,  I don't have an Edge Transoprt server in my Org.

TalkExchange,  I have tried these fixes and end up with either Outlook 2011 being completely unable to attach to the server.  I tried tuning the values, but I am still unable to attach over 2 Megs.

Anything else I can try?
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I actually found out that the Outlook 2011 was using Autodiscover to point to our front end server, which does have mandatory limits.  I was able to tell Outlook 2011 to stop using using autodiscover by running the following applescript:

tell application "Microsoft Outlook"
      set background autodiscover of every exchange account to false
end tell

This doesn't fix the root of the problem, but at least is an acceptable work around.

Thank you for all your suggestions.