Link to home
Create AccountLog in
Avatar of G0ggy
G0ggyFlag for United Kingdom of Great Britain and Northern Ireland

asked on

The Type or Namespace Does Not Exist

Hi everyone,

Please bear with me, this is quite a specific issue which I'll try and detail as best I can.

I've inherited a couple of Visual Studio projects, one of which references another. In a class in a project called TCG.Toolkit there is a reference to a class called The1440.Classes.Designer.

This project used to compile without any problems, now the Designer bit of the the using statement has a red underline and in the references section of the project there is a little yellow triangle next to the reference.

I have tried adding in the reference again but I cannot see a class called Designer in the The1440.Classes project.

I have tried changing the .NET version from 4 to 3.5 and back again as I read somewhere that this can sometimes cause the problem.

Please let me know what other information you may need to solve this problem.

Thanks in anticipation.
Avatar of Kash
Kash
Flag of United Kingdom of Great Britain and Northern Ireland image

well, if you cannot see the designer class then thats where the problem is. what happens if you comment that code which refers to this designer class. does it compile ok?
Avatar of G0ggy

ASKER

No, there's other references in the Class which may have been in the missing class, although it's tough to say how things were set-up before it went awry.

There is a class in the TCG.Toolkit, within the library folder, called Designer.cs - do you think it's possible that this has been dragged by mistake across the projects?
ASKER CERTIFIED SOLUTION
Avatar of G0ggy
G0ggy
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of G0ggy

ASKER

I really can't explain with this had happened, but if my solution helps someone else not to feel like they're banging their head against a wall, I'll be happy.