Link to home
Create AccountLog in
Avatar of trazodone
trazodoneFlag for Thailand

asked on

Telnet from linux shell to GSM module has no response message

Hello Expert,

I have GSM module connected to my local network. When I telnet using putty, Every command I send to modem is ok that I issued AT command "atz" and GSM modules response "OK" back to me. please see below

===================
Using putty connect to 192.168.1.111 port 11111
===================
atz
atz

OK
atz
atz

OK
atz
atz

OK
===================


The problem is when I login to my linux server on the same local network and telnet to GSM modules, I can send AT Command but no response message back to me please see below


===================
shell>telnet 192.168.1.111 port 11111
===================
shell> telnet 192.168.1.111 11111

atz
atz




atz
atz


atz
atz
atz
atz




atz
atz


===================

Please help to investigate. Thank you.
Avatar of kevinhigg
kevinhigg

Good day.  It sounds as if local echo may be toggled off for your telnet session.  You can try ^e (control+e) to toggle it on.  For more detail, see the man page:

http://linux.die.net/man/1/telnet

Kind regards.
Avatar of trazodone

ASKER

^E already but nothing changed
Just re-read your post; so it's the telnet daemon that's expected response isn't visible in your client?  Are you doing anything specific in putty to change the terminal or emulation type?
I know the problem is my shell in my linux server that is "ash" from "synology" custom linux. By the way I don't know how to fix this telnet problem in my NAS.
ASKER CERTIFIED SOLUTION
Avatar of trazodone
trazodone
Flag of Thailand image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Found answer by myself