?
Solved

Unable to RDP onto computer but able to ping OK.

Posted on 2012-07-05
16
Medium Priority
?
8,674 Views
Last Modified: 2012-07-10
Hello amazing people!

I am currently trying to log onto two computers in the office via RDP but unable to do so.
I am able to ping the computers OK.

I have checked all RDC settings on the computer and all is enabled. I have tried restarted the services but still no joy.

I had run a virus scan but it may have not been a virus and just the scandisk USB application which was popping up. Doing a full scan on the system and 2 viruses popped up with scandisk USB on it.

I have tried renew IP address and flushing DNS but no joy.

I am able to manage the computer remotely OK.

Tried to readd the computer onto domain and still no joy with RDP.

Run SFC scan but still no joy.

I have checked everything i can on google and windows website but unable to find anything therefore hope you can help.

Computers has Windows 7 Pro on them.
0
Comment
Question by:support01
  • 7
  • 4
  • 2
  • +2
16 Comments
 
LVL 3

Assisted Solution

by:Nanders81
Nanders81 earned 250 total points
ID: 38155291
Have you checked the Windows Firewall? Disable it and try again.
0
 

Author Comment

by:support01
ID: 38155314
The firewall has been disabled but still no joy. We have trend micro as AV solution.
0
 
LVL 3

Expert Comment

by:Nanders81
ID: 38155331
OK. Try to add this to your GPO:
Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Terminal Services -> Terminal Server -> Connections:

"Allow users to connect remotely using Terminal Services:"-> Enabled
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
LVL 6

Assisted Solution

by:MPJHorner
MPJHorner earned 250 total points
ID: 38155422
If you are out of the office and they are in the office do they each have seperate IPs or have you configured a port forward? Would check theses are correct.


Also check that the Computers are 'remote desktop enabled' and also check that windows firewall rule is for the correct profile ie 'domain, private, public' that match your settings (probably domain) .

run a portscan to check the port is open.

Hope this helps :)
0
 

Author Comment

by:support01
ID: 38155568
Nanders81 that has already been done. As for IP addresses and port forwarding the RDP ports are open, when i am out of the office i am able to RDP onto the other machines but these two. I have checked that remote desktop is enabled. Windows firewall is turned off at the GPO.
0
 

Author Comment

by:support01
ID: 38155607
Would like to add i am unable to RDP onto it in the office our outside the office.
0
 
LVL 3

Expert Comment

by:Nanders81
ID: 38155666
Check the IP-settings. Do these machines use the correct Gateway and subnet?
0
 
LVL 3

Expert Comment

by:Nanders81
ID: 38155720
Do you connect to the computers thru IP or DNS? Try the IP-address in case of DNS.
0
 

Author Comment

by:support01
ID: 38155727
I have tried via IP and computer name but no joy. The IP details is ok as the computers get DHCP. Tried applying static IP address but still no joy.
0
 
LVL 14

Assisted Solution

by:Don Thomson
Don Thomson earned 250 total points
ID: 38156709
If you are able to RDP into other computers from an external location - and they are all behind a standard router, then you must be using port forwarding to accomplish this

The standard RDP port is 3389 - If a router forwards that port to a particular IP address internally then all calls to that external IP on port 3389 will go to that Computer and only that computer. (The exception is if you are going through SBS  and it's handling the traffic)

Regardless if your Firewalls are on or off or port are opened on any particular machine - The user must be a Mobile user, Administrator, or a member of the Remote Desktop security group in order to connect using RDP

You can alos change the RDP port in an individual machine and let the router handle the traffic. In normal cases where the Port is 3389 - you simply put in the external IP Address and whereever port 3389 is forwarded to is where the RDP will go. If you change the port to say 3390  then you need to change your host setting in the RDP Client to do for instance 10.45.34.22:3390  in order to get to another machine. If you do this you need to either change the Port on the PC or have a router capable of modifying an incoming port to another ip/port

For instance say you have PC-A  and PC-B
Both have 3389 as there default port
say PC-A is 192.168.0.111  and PC-B is 192.168.0.112

In the Router you can specify that all traffic on port 3389 be forwarded to 192.168.0.111  on port 3389

For PC-B - you need to tell the forwarding that al traffic on port 3390 goes to port 3389 on 192.168.0.112

To get to PC-A your use <your External IP>
To Get to PC-B you use <your External IP>:3390
0
 

Author Comment

by:support01
ID: 38159106
Ports have been forwarded correctly. I am unable to RDP onto these computer event within the network.
0
 
LVL 16

Expert Comment

by:cantoris
ID: 38161602
I presume your user account is a member of the Remote Desktop Users group on those computers?
0
 
LVL 14

Expert Comment

by:Don Thomson
ID: 38166225
cantoris - Already mentioned that (paragraph 3)
0
 
LVL 16

Accepted Solution

by:
cantoris earned 250 total points
ID: 38168536
Can you connect to these computers from within the office using other tools - eg pointing the event viewer snap-in at them?

Can you telnet to their port 3389 from within the network and get some form of response?
0
 

Author Comment

by:support01
ID: 38170494
Hello People, thank you for your help but i just ended up reinstalling windows. I have not tested yet but will try and fingers crossed it should work. Will reopen question if the problem is still there, Again thanks for your help!
0
 

Author Closing Comment

by:support01
ID: 38170502
Was unable to resolve issue. Had to reinstall windows. Will now test and hope it works.
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

At the beginning of the year, the IT world was taken hostage by the shareholders of LogMeIn. Their free product, which had been free for ten years, all of the sudden became a "pay" product. Now, I am the first person who will say that software maker…
There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
Suggested Courses

594 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question