Link to home
Start Free TrialLog in
Avatar of USAVolleyball
USAVolleyball

asked on

Comcast PRI + Dialogic Gateway, no ringthrough

We moved our corporate HQ to a new location that is being serviced by a Comcast PRI line (split off from our Fiber connection)

When we set the system up, everything worked fine, and still does for the most part, however calls INTO the system receive no ringing sound when calling a party within our organization.  

If you were to call my extension directly, the phone rings once on the earpiece, and then there's dead air until either A) I answer, or B) my voicemail picks up.  

Calls out have zero issues.  This issue is only present for people calling INTO the company.  

Comcast, Dialogic, and our IT vendor are all shrugging - no one has anything I can check or any settings that need to be changed.  

Sequence of the PRI:

Comcast - > PRI -> Comcast Equipment -> Handoff to our Dialogic -> Dialogic to OCS Cluster

I can't find any settings in the OCS setup that would fix this particular issue, and since no one was paying much attention until the problem was reported, we don't know if the ringing ever worked at the new building, or if it is a recent issue.
Avatar of jgerbasi
jgerbasi
Flag of United States of America image

I doubt it is the PRI since calls can actually be answered. It would most likely be a setting in the station set up for Audible Rings it might only be set to 1 instead of lets say 4.
Avatar of USAVolleyball
USAVolleyball

ASKER

Problem is, where would such a setting be at?  I haven't had any luck in my searches for such a setting.  Nothing has changed on our setup since we moved locations (in terms of our actual OCS setup)
Go into the Station or Extension setup of any extension. There should be a setting for rings there.
This is a global problem - isn't there a way to fix this for everyone instead of each user?  I need to make this change across every connection, but I don't see how to do that from any system.
Please do keep in mind I'm referring to the ring being played for the person who is CALLING us, and not merely the rings that we hear on the phones on our desks.
Try this hopefully it applies to the version you have...
When the DMG4000 sends the SIP call to OCS and gets a ring back it sends an ISDN 'Alert' message to the 5ESS switch. The switch should then send a ring to the person calling you.

If the switch isn't sending the ring then you could ask the switch operator to look at changing the configuration if possible.

If this isn't possible you can change the DMG configruatio so that it generates the ring tone.

The possible downside is that the ringtone generated is not necessarily localised so may sound a little odd but generally it is recognisable as a ring tone.



So, open the diva Server configuration manager, select View/Extended.

Click on the PRI line 'plug' and in the right hand panel change 'Generate ring tones' to Yes.

Do File/activate, reboot if requested and test away.
sorry, diva server configuration manager?
It should just be in the Server Config Manager. forget the Diva part.
Which server are you recommending this change be made from?  I don't see any menus / configurations that you are mentioning here.  

This is OCS 2007 R2, if it helps.
In OCS can you go to the VoIP Host Group Settings? Does the value have just an IP or an IP:PORT?
No idea where that menu is - I was literally thrown into this position, I have no prior experience with OCS, I can access the management interface on each of the OCS members through compmgmt.msc but that's about it.  

This is the only interface I've ever been able to find for the OCS system, see attached.  

It also might help to know which server I should be looking at.  Mediation, AV/Edge, OCS Main, etc.
It should be on the Dialogic server under Configuration -> Routing Table -> VoIP Host Groups
We're using a DMG2030.  I've never seen VoIP Host groups in the device UI itself.
Sorry, I was looking for a submenu - I've got the correct page now.
Here's what our configuration looks like in the VoIP Host Groups menu.
VoIP.JPG
The IP it is referencing is an IP on the Mediation server, the port is correct as well.
Im sorry at this point I would recommend calling Dialogic for support. I am sure they have dealt with this in the past and may be able to further assist.
Yeah, they've tried.  Thus this post.
Last resort Idea have you tried rebooting all devices? Dialogic server and handoff?

Sometimes simple things work as we all know.
Indeed.  It was one of the first things we tried.  :)
ASKER CERTIFIED SOLUTION
Avatar of USAVolleyball
USAVolleyball

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Resolved issue on our own in December, 2012.