Link to home
Start Free TrialLog in
Avatar of Brad Sims
Brad SimsFlag for United States of America

asked on

Dimension 5100 Possible Short in Motherboard?

Hi all,

I'm working on a Dell Dimension 5100 PC.  It came with the Thermaltake 430W power supply, and my friend said she was working on it one day and it froze on her.  She said it wouldn't power on at all.  I swapped the power supply with mine (since I know it works - and it's 500W), and it booted up.  Thinking this was the problem, I put it back together and tried to boot it up again.  It wouldn't boot all all, no power, no diagnostics lights, just the green light on the motherboard.  The odd thing is, if I take all of the RAM out the fans come on and the system beeps.  It also will boot if I reset the CMOS jumper, but only once.  If I turn it off again nothing happens.

Any idea what could be causing this?
ASKER CERTIFIED SOLUTION
Avatar of sweetfa2
sweetfa2
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Are there are bulging or leaking capacitors on the motherboard?
Avatar of Brad Sims

ASKER

It's not the power supply.  I've tested with two different known working power supplies, both of higher ratings.  I also have a power supply tester, and both tested good.

I checked the motherboard and do not see any bulging or leaking capacitors.  I know Dell is infamous for that on some of their older models :)
Did you try the short option.
sweetfa2 is correct that Dimension 5100 PCs are rather ticky about power supplies. However, a 430 watt or 500 watt should be more than sufficient. If I remember correctly, they came with a 350 watt PSU.

also, take jamietoner's advice and check the caps.

Is your 500 watt PSU a decent quality one? 30 amps on the +12VDC rail is desirable.
Have you tried replacing the cmos battery?
I've tried two different power supplies.  One at 500W which I use daily in my home machine.  The other was an 850W power supply that I just used to build a gaming machine.  I will try the power supply thing just to rule it completely out though.

I have replaced the CMOS battery because I just happened to have a new one handy from a previous build.  The voltage on the other battery tested at 3V though as well.
Avatar of Grant1842
It is possible that some of your electrolytic capacitors are bad. But you will need an ESR meter to find out the ones that are the problem.

Link to ESR meter
start troubleshooting with a minimum setup, as described here :
https://www.experts-exchange.com/Hardware/Components/Motherboards/A_1945.html                  (Short-overview-of-how-to-troubleshoot-bad-hardware-when-a-pc-does-not-post)

in the case that the disk shows problems, you can use this guide to handle it :
https://www.experts-exchange.com/Storage/Hard_Drives/A_3000-The-bad-hard-disk-problem.html
It was the power switch (on the front panel) that was malfunctioning.  Of course Dell uses a proprietary cable for their front panel connectors.

Accepting sweetfa2's comment on the basis that the article mentions the computer booting up with the power supply shorted if the front panel connectors are bad.