Avatar of sio2y
sio2y
 asked on

Extend OWA public timeout

Hi,

We would like to extend the default timeout for owa on public computers. We have found several threads for a reg edit however we would rather do it through the emc or maybe even ems.

Thanks.
ExchangeSBS

Avatar of undefined
Last Comment
sio2y

8/22/2022 - Mon
sio2y

ASKER
we have attempted this ems cmdlet but get an error on Set ItemProperty.........

Set-ItemProperty 'HKLM:\SYSTEM\CurrentControlSet\Services\MSExchange OWA' -name PublicTimeout -value 180 -type dword
Jamie McKillop

Hello,

Are you running that command from the console of the CAS server? Have you tried modifying the value with registry editor?

JJ
sio2y

ASKER
Hi,

Thanks for the reply -

Yes and no....we are running sbs 2011 sp1. We really wanted to do it throught he ems or emc if possible.

The error we get from ems is that theres an authorization issue.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER CERTIFIED SOLUTION
Jamie McKillop

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Md. Mojahid

which state this addition to registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeOWA
    Name: PublicTimeout
    Type: DWORD
    Value: {value in minutes} (This value is 15 minutes by default)  <--- I set this to 180 (3 hours)

I made change on both of my CAS machines and restarted IIS on both.  I then login using public option via OWA and wait 15 minutes to see if it logs out...SADLY, it does log me out after 15 minutes.

Note before doing this please make sure you should have registry proper backup in your hands.
sio2y

ASKER
Thanks for the response -

WE would like to do it in ems for a couple of reasons but primarily 'cause if we do it incorrectly we get an error code.

 We can't post the error at the moment but will when we get back to it.
sio2y

ASKER
Here's the ems error code:


Set-ItemProperty : Cannot find path 'HKLM:\SYSTEM\CurrentControlSet\Services\MSExchange OWA' because it does not exist at line 1 char:17
*set-ItemProperty <<<<<'HKLM:\SYSTEM\CurrentControlSet\Services\MSExchange OWA' -name PublicTimeout -value 180 -type dword
*CategoryInfo  :ObjectNotFound: <'HKLM:\SYSTEM\....MSExchange OWA:String> [Set-ItemProperty}, ItemNotFoundException
*FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.SetItemPropertyCommand
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
sio2y

ASKER
My oversight that I wasn't running ems as full admin (thanks for bringing it to my attention)........changed that and the cmdlet was accepted.