Link to home
Start Free TrialLog in
Avatar of Bakersville
BakersvilleFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Incoming email in sharepoint 2010 now longer working.

Hi everyone.

Sorry to do this, but i have been searching for hours and can not seem to sort this problem out.

I am running a test environment to start using Sharepoint 2010. Single Server Farm.

I have setup exchange/sharepoint to enable incoming emails into sharepoint and they it is sending emails to helpdesk@server.domain.co.uk without any problems and putting the emails into C:\inetpub\mailroot\Drop. However, they are just staying in the folder.

All services used including smtp, Local Service, Network Service, WSS_ADMIN_WPG and WSS_WPG and all these have permission to the drop folder.

I have also created the document library to accept incoming emails from any sender.

When i first created the document library, it worked and i had 2 emails in the library 2 days ago, now just tested it again, and it is keeping the emails in the drop folder and not putting them into my library?

Does anyone know why or how i can fix this.

Thank you
Baker
Avatar of Justin Smith
Justin Smith
Flag of United States of America image

What is your config version number?  You can find it on System Settings - Servers in Farm, in Central Admin.  If you have installed the April CU for 2010, it has a bug that kills incoming email in some situations.
Avatar of Bakersville

ASKER

Hi Ach1lles

The version number is
Configuration database version: 14.0.6029.1000

Is that what you meant?
Ok, that is SP1.  Not the troubled version, but you are still on an "unstable" version according to Microsoft.  They recommend installing at least June CU with SP1.  I'd recommend just deploying the Feb CU instead.  But that's another topic :)


So, your incoming email was working at one point, correct?  Right now email is being sent to the drop folder correctly, but SharePoint never picks it up?  Is your timer service running?  Is the Incoming Email timer job completing?  You can go to Monitoring - Job Definitions (in Central Admin) and run the job manually.  It's called Microsoft Foundation Incoming Email.
The Sharepoint 2010 Timer is running, it uses the Network Services Account.
The Timer Job on sharepoint is running every minute and completing sucessfully, also, i have ran it manually and still not picking up the email.
Did you say this was working previously?  If not, have you doublechecked your incoming email configuration in Central Admin?

How many mail messages are waiting there?
It was working. But when it stopped i deleted the library and started again, just in case.

In the Central Admin -> System Setting -> configure Incoming email, if have

Enabled, Advanced.
No to using Sharepoint Directory
Email server display name = server.domain.co.uk
E-mail drop box = C:\inetpub\mailroot\Drop

Now within the Site, i have created a library with no default file types.

Then went into Incoming E-Mail setting and have

Set allow the document library to receive emails
E-mail address : helpdesk@server.domain.co.uk
Save all attachment in folders broup by email sender.
Don't overwrite
Save original emails
not to save invitations
Accept emails from any sender.

Surely this should work?

Baker
I'm curious.....if you assign the Library a name that it didn't have previously, like helpdesk2, will it pick them up at that point?  Obviously you'll have to send new test messages to the new email address.
No.  I changed the library names and email addresses etc, just in case.

Still not working
ASKER CERTIFIED SOLUTION
Avatar of Justin Smith
Justin Smith
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
thank you.  Finally sorted, just uninstalled and reinstalled and all fine now.