BOOTMGR is missing on Windows Server 2003

I had a failed disk on a Windows Server 2003 R2, and after the disk got replaced, I got "BOOTMGR is missing, press Ctrl+Alt+Del to restart".  I know there's a way to fix these type of errors in Windows XP by replacing the "ntldr", "ntdetect.com", and "bootcfg /rebuild", but don't know what to do for Windows Server 2003.  Please advise.  Thanks..
LVL 1
swgitIT ProfessionalAsked:
Who is Participating?
 
swgitIT ProfessionalAuthor Commented:
Nothing works so far.  The only option I have now is running the second "Repair" option, the one that actually replaces the Windows files after hitting Agree (F8) on the License Agreement.  I'm thinking that this option would break applications one way or another, and will cause more problems.  I have not done this type of thing on a production server.  What would you suggest?  Please advise.
0
 
mi3erCommented:
Hi, if you didn't delete this files then problem with permissions.
http://support.microsoft.com/kb/883275
0
 
Premkumar YogeswaranAnalyst II - System AdministratorCommented:
Hi,
Reseat all internal data and power cables:
BOOTMGR error messages could be caused by unplugged, loose, or malfunctioning power or controller cables.

The most common reasons for BOOTMGR errors include corrupt and misconfigured files, hard drive and operating system upgrade issues, corrupt hard drive sectors, an outdated BIOS, and damaged or loose IDE cables.

Another reason you might see BOOTMGR errors is if your PC is trying to boot from a hard drive or flash drive that is not properly configured to be booted from. In other words, it's trying to boot from a non-bootable source. This also would apply to media on an optical drive or floppy drive that you're trying to boot from.

Bootcfg command, use to fix the boot configuration issue.
Check the below link for 2003 Server
user bootcfg /rebuild command

http://support.microsoft.com/kb/317521

Regards,
Prem
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
footechCommented:
I would run the fixboot and fixmbr commands from recovery console.
0
 
footechCommented:
I've never done a repair install on a production server.  To be honest, although I would be curious about its results, if I got to the same point and didn't have any other options  I would elect to either restore the machine (if a backup was available) or rebuild.

First, however, "Nothing works so far."  Can you elaborate, what steps have you tried?
0
 
swgitIT ProfessionalAuthor Commented:
@mi3er - this is not permissions problem, but thanks for your input<br />@prem - this is how i used to fix boot problem for windows os, however, it didn't really work in this case after i tried.  thanks for reminding me of the other options<br />@footech - "Nothing works so far" means the following steps did not fix the problem:<br />
replaced "ntldr", "ntdetect.com", and ran "bootcfg /rebuild" in the recovery console did not solve the problem
<br />
also from the recovery console, "fixboot" and "fixmbr" did not solve the problem either
<br /><br />So I ended up doing the following:<br />
imaged all disk partitions just in case
<br />
repaired windows ("Repair" option after F8) > this resulted in successful boot up to Windows. However,
<br />
all system drivers need reinstalled
<br />
network configuration needs reconfig'ed or applied
<br />
all Windows updates reapplied
<br />
restored most recent backups
<br /><br />So far so good... there are minor errors here and there between the app and database, but I'm okay with the result now, as I can get thing up and running, even with some errors.<br /><br />Thanks all for your help.  Please do let me know if you have any questions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.