Cannot e-mail to distribution lists

aptnrickard
aptnrickard used Ask the Experts™
on
We are using SQL 2008 Reporting Services and are running into an issue where we can't send a report to an Exchange DL unless we turn off "require authentication".  We can send to a specific individual without issue.

The error we get is:  #550 5.7.1 RESOLVER.RST.AuthRequired; authentication required ##

We are using Exchange 2010 if that matters.

We have checked the following so far:
*Setup Exchange to allow our report server to send through it
*Verified our Reporting Services service account has Send As permission to the mailbox we are sending from
*Modified the rsreportserver.config file so the RSEmailDPConfiguration section  looks like this:
<SMTPServer>mailserver</SMTPServer>
<SMTPServerPort>
</SMTPServerPort>
<SMTPAccountName>
</SMTPAccountName>
<SMTPConnectionTimeout>
</SMTPConnectionTimeout>
<SMTPServerPickupDirectory>
</SMTPServerPickupDirectory>
<SMTPUseSSL>
</SMTPUseSSL>
<SendUsing>2</SendUsing>
<SMTPAuthenticate>2</SMTPAuthenticate>
<From>reports@domain.com</From>
<EmbeddedRenderFormats>
      <RenderingExtension>MHTML</RenderingExtension>
</EmbeddedRenderFormats>
<PrivilegedUserRenderFormats>
</PrivilegedUserRenderFormats>
<ExcludedRenderFormats>
      <RenderingExtension>HTMLOWC</RenderingExtension>
      <RenderingExtension>NULL</RenderingExtension>
      <RenderingExtension>RGDI</RenderingExtension>
</ExcludedRenderFormats>
<SendEmailToUserAlias>True</SendEmailToUserAlias>
<DefaultHostName>
</DefaultHostName>
<PermittedHosts>
</PermittedHosts>

Unfortunately we're not seeing any changes in the behavior.

Are we missing something?

Cheers
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
kevinhsiehNetwork Engineer

Commented:
You need to allow anonymous senders to send to the distribution groups. By default, only authenticated users can send email to distribution groups.

The instruction are under part 11 of the document. There is a check box.

Use the Mail Flow Settings tab to configure message size or message delivery restrictions for the distribution group. To view or change a mail flow setting, select the setting from the list, and then click Properties.
...
Require that all senders are authenticated   Select this check box to prevent anonymous users from sending messages to the group. By default, this check box is selected for distribution groups. This prevents external senders from sending messages to distribution groups.

http://technet.microsoft.com/en-us/library/bb125178.aspx

Author

Commented:
Thanks, we've done that as a temporary work around but we don't want DLs to be accessible from outside going forward.

I used these articles as my guide:
http://technet.microsoft.com/en-us/library/ms345234(SQL.105).aspx
http://technet.microsoft.com/en-us/library/ms159155(v=sql.105).aspx

Based on those, if we set SMTPAuthenticate to 2 in the rsreportserver.config file and give the service account Send As permissions on the mailbox, it should work.

The service account is a domain account and I have verified that the password has not expired or been changed.
Not sure what is different since we tried stopping/starting the reporting services with no luck but when we actually rebooted the server it started working.

The MS tech notes said we didn't need to do this but we tried this morning just in case.

Cheers

Author

Commented:
Reboot resolved even though MS tech note said this was not necessary.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial