Stop Report Schedule window opening on login

tomhr
tomhr used Ask the Experts™
on
This is a pretty interesting one. Client called and said that a user is getting an error on login. The error message said "You don't have security privileges to open this window." The window pop-ed up before the homescreen finished loading. The user can click OK and move on.

I followed a blog post (http://blogs.msdn.com/b/developingfordynamicsgp/archive/2008/11/17/how-to-resolve-security-errors-on-login.aspx) and discovered the cause: The user did not have access to the Report Schedule window. I granted the user the task and now when they log in they do not get an error but the Report Schedule window.

However, they are not supposed to have access to this window. I cannot seem to find how to surpress it on login. I've looked through the documentation and it does not mention "login" or "pop-up" or anything of that nature.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Hi,

That sounds pretty odd.  I have never had to use the Report Schedule window, so I'm not aware of any option it may have that would have it open automatically, and I also don't see anything in the Report Scheduler documentation.

The only thing I can think of is that there is the "Startup" shortcut folder in GP that does allow you to open windows automatically when GP is launched.

Can you check to see if the user has anything listed under the Startup folder? (screen shot attached)


Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified IT Professional
ReportScheduleStartup.jpg

Author

Commented:
Thank you for the reply, Steve. I could not remember where the Startup folder was. However, this user's Startup folder is empty. I can log in as other users on the workstation and nothing occurs, so I'm guessing this information is stored in the database. I'll try a trace to see if anything is in there.

Author

Commented:
Got it, it was not showing up in her Startup folder but it was in the database (DYNAMICS..SY01990). Deleted the record and the window no longer pops up. Thanks for the help, Steve.

Commented:
Hi,

Good find!  I wouldn't have thought to check for a record in the database in lieu of the shortcut.

Glad that solved the problem.

Thanks,

Steve Endow
Dynamics GP Certified Trainer
Dynamics GP Certified IT Professional

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial