SBS 2003 SP2 - Terminal Services Service Wont Start - Error 126 - Specified Module cannot be found

Hi all,

We have a customer that has an SBS 2003 Sp2 box that no longer has the ability to be rdp'd into.  The terminal services service fails to start with an error message:

Could not start the terminal services service on local computer.

Error 126: The specified module could  not be found.

I have tried to search around and can only find reg fixes and resolutions for XP machines.  I have replaced the termserv.dll in c:\windows\system32\ dir and still the same.

What else can i try?
msha094Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Have you reviewed this KB article yet?
http://support.microsoft.com/kb/959077

If that doesn't resolve it, then run an sfc /scannow command.

Jeff
TechSoEasy
msha094Author Commented:
That article relates to the Windows Modules Installer service, but has the same error 126 code.  I have an issue with the terminal services service instead.

I have also run a sfc /snannow to no avail.
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
How did you replace the termsrv.dll file?

The file should be on the CD as \i386\termsrv.dl_  and must be copied to the system32 directory using the EXPAND command.

ie:  
expand X:\i386\termsrv.dl_ -r C:\WINDOWS\system32\termsrv.dll

Open in new window


(where "X" is your CD-ROM drive)

Jeff
TechSoEasy
Get a highly available system for cyber protection

The Acronis SDI Appliance is a new plug-n-play solution with pre-configured Acronis Software-Defined Infrastructure software that gives service providers and enterprises ready access to a fault-tolerant system, which combines universal storage and high-performance virtualization.

msha094Author Commented:
I actually simply copied it from another customers SBS box and renamed the existing to .old and dumped the new one in.  Not correct?
msha094Author Commented:
Anyhow that didnt resolve either.  Same error 126 code.
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Apparently there is a registry fix for this which may resolve the problem.

Please be sure to first make a full backup of your registry, then copy this file to the Server's desktop:
http://windowsxp.mvps.org/temp/termservice.reg

Open the file and then say "yes" to allowing it to merge into the registry.

Reboot the server and see if the service starts.

FYI, Server 2003 is the same as Windows XP, so the fix would be fine to use on your SBS 2003.

Jeff
TechSoEasy

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.