?
Solved

Out Office Assistant not working on outlook

Posted on 2012-08-10
22
Medium Priority
?
755 Views
Last Modified: 2012-12-18
Guys..

none of the users can access the Out Office assistant on outlook by they can on the web outlook.. I dont know how this happend i hve been having issues with an old exchange 2003 server and had to do a hard delete from the forest. looks like this broke the link to OOA from outlook clients.. how do I fix it?

thanks
0
Comment
Question by:goodwill1
  • 11
  • 8
  • 2
  • +1
22 Comments
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38281669
Can you please check if your Certs are not expired ?

- Rancy
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38282606
Your E2003 wouldn't affect OOO on E2k7 box.

Let us start from basics, Right click on OL icon on system tray, click on Test Email Auto Configuration, uncheck two checkboxes that has "Guesmart". Type in your password and hit enter.

Provide the log for us to review (possible screenshot should also work)

Regards,
Exchange_Geek
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38284598
What is the Exchange version and what error do you get when you try to set OOO from Outlook ?

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38288537
Hi guys.. the exchange cert is not expired.. I can access OWA and other resoueces just fine. the exchange version is 8.3 and the error is ( Your Out of the Office setings cannot be displayed, because the server is currently unavailable. Try again Later.
\I got this for every users just from outlook not OWA

thanks
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38288737
OWA doesnt use Autodiscover so it works fine ... so its either an issue with your certs or Outlook unable to connect to Autodiscover .....

Check all Exchange related services are running on the Servers.
Is Outlook in Online or cache mode ?
Outlook 2010: Test Email Auto Configuration
http://www.addictivetips.com/microsoft-office/outlook-2010-test-email-auto-configuration/

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38289409
I run the test and there are issues with autodiscover.. I forgot to mention that we have a coexistence scenario with exchange 2007 and 2010. so I dont know if autodiscover will create an issue. attached is the screenshoot.. I think this all will get fix when moving all to exchange 2010 and decomission the exchange 2007

thanks
Email.png
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38289576
I agree but thats sometime to go ..... Need to understand users on E2k7 arent using CAS of E2k10 ?

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38292779
Rancy.. users on Exchange 2007 are using CAS 2007. right now only me and the IT team are on the exchange 2010 server. the rest of the users are on 2007.
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38293137
So the 2 accounts moved arent able to connect to Autodiscover ?
Hope they both connect to E2k10 CAS ..... are you able to browse
http://E2k10CASName/Autodiscover/autodiscover.asmx

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38293546
everytime I run the test email configuration it failed. but the one sthat are on 2010 exchange OOA works just fine. is just for the users on 2007 exchange that OOA is not working on outlook. and Not im not able to browse http://E2k10CASName/Autodiscover/autodiscover.asmx
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38293858
You do not have any A record nor SRV Record created for your environment w.r.t autodiscover - how would you expect OA to work for you externally?

> autodiscover.goxxxx-sunxxxxt.com

*** UnKnown can't find autodiscover.goxxxx-sunxxxxt.com: Non-existent domain
> set q=srv
> _autodiscover._tcp.goodwill-suncoast.com

*** UnKnown can't find _autodiscover._tcp.goxxxx-sunxxxxt.com: Non-existent domain

You'll need to either add autodiscover.goxxxx-sunxxxxt.com to your CERT and have an A record created externally pointing to your webmail address

OR

have a SRV record _autodiscover._tcp.goxxxx-sunxxxxt.com and point it to your webmail address.

If the above two aren't followed and cert details doesn't include the following

autodiscover.goxxxx-sunxxxxt.com
webmail.goxxxx-sunxxxxt
CAS Server NETBIOS
CAS Server FQDN

Regards,
Exchange_Geek
0
 

Author Comment

by:goodwill1
ID: 38295847
Yes that make sense.. when I created the cert i did not included autodiscover.domain.com, i dont have any record on DNS for autodiscover.. the problem is since I have exchange 2007 and exchange 2010 on coexistence.. where do I point to the autodiscover record to exch 2007 CAS or Exch 2010 CAS?

thanks
0
 

Author Comment

by:goodwill1
ID: 38386700
guys give me some time on this.. I will get back soon.. thanks
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38386746
Sure ... just keep us updated

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38399815
I got my new cert with the autodiscovery name on it. I will create now a dns  host with the name autodiscovery and point to my exchange 2010 server right?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38399850
Yes
0
 

Author Comment

by:goodwill1
ID: 38399862
question.. i have exchange 2007 and exchange 2010 on the same domain on coexistance do i need to point it to exchange 2007 or 2010?.
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38401472
Look ideally it should be pointing to E2k10 as thats where your planning to move ?
Where are the users mailbox at the moment ?

- Rancy
0
 

Author Comment

by:goodwill1
ID: 38406800
Hi Rancy..

I have 95% of the users on exchange 2007, and just a 5% on exchange 2010. I have a question.

I was looking at the settings and something sparked to me.. on the security cert and on the dns host the name should be autodiscover.domain.com or autodiscovery.domain.com? I think is autodiscover but I have autodiscovery instead. please let me know
0
 

Accepted Solution

by:
goodwill1 earned 0 total points
ID: 38687611
I was able to fix this problem, it was my fault I setup the cert with the wrong DNS name. it should be autodiscover and it was autodiscovery after I fixed that on the cert allk was good!!

thanks guys
0
 

Author Closing Comment

by:goodwill1
ID: 38701297
I was able to realialized of the differences betweeen autodiscovery and autodiscover DNS name on cert.
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If something goes wrong with Exchange, your IT resources are in trouble.All Exchange server migration processes are not designed to be identical and though migrating email from on-premises Exchange mailbox to Cloud’s Office 365 is relatively simple…
I came across an unsolved Outlook issue and here is my solution.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses
Course of the Month15 days, 22 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question