• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1043
  • Last Modified:

Trying to setup Citrix to demo. I am stuck in the setup of the Presentation server.

I was just trying to setup to enable remote users to have access to a remote desktop?   I got this error when I  gave them a link.       https://mycitrix/CitrixAccess/


Here is the error I get.

 
Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
0
patrickmiller
Asked:
patrickmiller
  • 2
1 Solution
 
Kent DyerIT Security Analyst SeniorCommented:
Can you run the app locally from the server?

Have you tried to give the IP address instead in the event there is a DNS issue?

I would start there..

HTH,

Kent
0
 
patrickmillerAuthor Commented:
Here is what I get locally.
Under Construction


The site you are trying to view does not currently have a default page. It may be in the process of being upgraded and configured.

Please try this site again later. If you still experience the problem, try contacting the Web site administrator.


--------------------------------------------------------------------------------

If you are the Web site administrator and feel you have received this message in error, please see "Enabling and Disabling Dynamic Content" in IIS Help.

To access IIS Help
Click Start, and then click Run.
In the Open text box, type inetmgr. IIS Manager appears.
From the Help menu, click Help Topics.
Click Internet Information Services.
0
 
Dirk KotteSECommented:
this means, your wi-site is not the default page.
goto webinterface-configuration, site maintenance and select the "use as default webpage" checkbox.
the creates a webinterface.htm file within your webserver-root that redirects the request to your page.
0
 
patrickmillerAuthor Commented:
That seemed to fix it.    Now i work on the security part of it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now