We help IT Professionals succeed at work.
Get Started

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

J.R. Sitman
J.R. Sitman asked
on
3,344 Views
Last Modified: 2012-09-12
I'm getting the error, "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {0C0A3666-30C9-11D0-8F20-00805F2CD064} and APPID {9209B1A6-964A-11D0-9372-00A0C9034910}.
EventID 10016.  

I researched Technet and tried the second solution below and it didn't fix it. I even added "everyone" and "domain users".

The first solution I didn't try because I don't have time to add every user we have.  I didn't reboot the server, so I don't know if that might help.

NOTE: this is only happening on 1 of our Citrix Servers

Any other advice would be helpful


Grant the user permissions to start the COM component
 Grant the user permissions to start the COM component. To do this, follow these steps: 1.Click Start, click Run, type regedit in the Open box, and then click OK.
2.Locate and then click the following registry subkey:

HKEY_CLASSES_ROOT\CLSID\CLSID value
Note In this subkey, "CLSID value" is a placeholder for the CLSID information that appears in the message.
3.In the right pane, double-click AppID.

The Edit String dialog box appears. Leave this dialog box open and continue to the next step.
4.Click Start, click Run, type dcomcnfg in the Open box, and then click OK.

If a Windows Security Alert message prompts you to keep blocking the Microsoft Management Console program, click to unblock the program.
5.In Component Services, double-click Component Services, double-click Computers, double-click My Computer, and then click DCOM Config.
6.In the details pane, locate the program by using the friendly name.

If the AppGUID identifier is listed instead of the friendly name, locate the program by using this identifier.
7.Right-click the program, and then click Properties.
8.Click the Security tab.
9. In the Launch and Activation Permissions area, click Customize, and then click Edit.
10.Click Add, type the user's account name, and then click OK.
11.While the user is selected, click to select the Allow check boxes for the following items: ¿Local Launch
¿Remote Launch
¿Local Activation
¿Remote Activation

12. Click OK two times.
13.Quit Registry Editor.

Grant the correct permissions to the Network Service account
 To grant the correct permissions to the Network Service account, follow these steps: 1.Click Start, click Run, type dcomcnfg in the Open box, and then click OK.
2.In Component Services, double-click Component Services, and then double-click Computers.
3.Right-click My Computer, and then click Properties.
4.Click the COM Security tab.
5.In the Launch and Activation Permissions area, click Edit Default.
6.Click Add, type Network Service, and then click OK.
7. While Network Service is selected, click to select the Allow check boxes for the following items: ¿Local Launch
¿Remote Launch
¿Local Activation
¿Remote Activation
 Click OK two times.

Back to the top | Give Feedback

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Back to the top | Give Feedback

MORE INFORMATION

 For more information about the x64-based versions of Windows Server 2003 and about Windows XP Professional x64 Edition, click the following article number to view the article in the Microsoft Knowledge Base:
888733

 A description of the x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition
 Back to the top | Give Feedback
Comment
Watch Question
Top Expert 2010
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE