We help IT Professionals succeed at work.

DNS time outs but eventually works

Medium Priority
185 Views
Last Modified: 2013-05-23
Hi guys,
Strange issue here.

I have a client that is having issues send out email from an Exchange Server. During troubleshooting i performed a NSlookup of the domain the client is trying to send to.

From the Domain Controller / DNS Server, if I run:

nslookup domain.com

It will fail, however if i type it again several times, it eventually provides me the correct information.


They have several domain controllers / DNS servers in the office and they appear to be all having the issue. They were using DNS forwards that point to their ISP but during troubleshooting I removed them and now using Root Hints.

These DNS servers are also virtual running VMware on ESXI. Are there any known issues on vmware that could cause this issue?
Comment
Watch Question

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
CERTIFIED EXPERT
Fellow
Expert of the Year 2017

Commented:
you could have a misbehaving dns server.

I would check the virtual servers network interfaces in use, if they are running e1000 legacy nics, replace with VMXNET3 interfaces, and make sure VMware Tools is installed to support these interfaces.

check replication between DNS servers, check and clear DNS caches. Update and check replication.

check each DNS server, test using dcdiag
piyushranusriSystem Cloud Specialist
Top Expert 2012

Commented:
for DNS server issue..
there are some steps.
as you do nslookup, check network setting on vm server as well as dns server
dns server ip address entries on domain contoller


as you said some times it provide the correct information...
will suggest you to check domain controller setting
Commented:
well, after more research its possible that disabling IPV6 causes the issue. Client is going to enabled IPV6 and reboot dc's and see how it behaves
piyushranusriSystem Cloud Specialist
Top Expert 2012

Commented:
please share the result...that is it resolved now ?

Author

Commented:
turned out that enabling ipv6 fixed the issue.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.