• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 632
  • Last Modified:

How to reinstall 3rd Party (GoDaddy) SSL Certificate on SBS 2008

We are experiencing issues with our SBS 2008 this morning for an unknown issue which is preventing Exchange Information Store from starting.
I believe that the SSL Certificate or Cert Store is having issues so wanted to go about removing and re-adding our 3rd party certificate.
How do I do this?
0
Flipp
Asked:
Flipp
  • 7
  • 6
  • 2
1 Solution
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
SSL certs have nothing to do with IS not starting .....

What error do you get and any event ID in Event Viewer ?
Check ADtopology service is started

- Rancy
0
 
FlippAuthor Commented:
Log Name:      System
Source:        Service Control Manager
Date:          13/08/2012 1:28:42 PM
Event ID:      7031
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      NAME.DOMAIN.local
Description:
The Microsoft Exchange Transport service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7031</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-08-13T03:28:42.000Z" />
    <EventRecordID>758</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>NAME.DOMAIN.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Microsoft Exchange Transport</Data>
    <Data Name="param2">1</Data>
    <Data Name="param3">5000</Data>
    <Data Name="param4">1</Data>
    <Data Name="param5">Restart the service</Data>
  </EventData>
</Event>
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
This error is for Transport service and not Information Store ?

- Rancy
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Did you try to restart the Transport service ?
Can you try to reboot the server if possible ?

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you tell me which all Microsoft Exchange services arent running ?

A bit background of the issue as well ...

- Rancy
0
 
FlippAuthor Commented:
Both Information Store and Transport Services are not running. Everything was fine until this morning when a scheduled restart occurred. Unable to restart or start either services.

BPA just run to find following errorwhich may have something to do with errors:
"internal network adapter is not configured to register ip address in dns"

Server has dual NICs but we disable one NIC and assign static IP.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Try to reboot the server ..... could be that NIC couldnt connect to DNS for some reason ?

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
The reason why i said to restart the server was maybe that can fix the issue rather quickly than us trying to troubleshoot .... if it still doesnt comes up we will be doing that .

- Rancy
0
 
FlippAuthor Commented:
Yes, I had already restart a number of times this morning, but after seeing that IPv6 was unchecked in NIC I re-checked and will restart and let you know in a few minutes.
0
 
FlippAuthor Commented:
Ok, so issue is still here ..... and after a restart a bunch of services fail. I am unable to open Services console to see even.

I have logged with MS Support so I might wait for their callback and let you know issue once they have sorted.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Look Ipv6 isnt needed ... just check if in Advanced settings on the NIC you have the options for "register ip address in dns" is checked.

What is the error you get when try to restart IS and is ADTopology service working.

Are you able to do nslookup and ping the DC\GC ??

- Rancy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
IPv6 may not be needed, but if you disable it you need to do it properly.  My suggestion is to keep it enabled.   See this article for further information.

http://blogs.technet.com/b/sbs/archive/2011/02/18/small-business-server-2011-slow-to-boot-and-several-services-fail-to-start.aspx

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
@Rancy -- I'm curious... have you ever deployed a Small Business Server?  If so, when and how many?

Jeff
TechSoEasy
0
 
FlippAuthor Commented:
Hi All .... as it turned out the certificate itself had lost its settings to complete the handshake, so we needed to re-import and apply etc.
0
 
FlippAuthor Commented:
Issue not resolved in troubleshooting, but had to reload certificate .
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 7
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now