We help IT Professionals succeed at work.

Server 2008R2 Remote desktop host disconnecting all connected randomly

Hi

Iam having some issues with my Windows 2008R2 terminal server disconnecting users randomly.

I have bought 15 Per user CALS for 2008R2 installed it on our central remote desktop license server. I have installed a Server 2008R2 instance and only installed Remote desktop service host and specified Per user licensing and specified the Central license server.

When Domain\Administrator connects the session will stay on for days. as soon as more than 3 people connect the session disconnects all users (including admin) randomly and also at random intervals. THe sessions stays open but changes to diconnected state.

I have done the following to troubleshoot and still the same issue.

Installed a brand new server 2008R2 server , added to domain, installed remote desktop host service and pointed to the central license server.... Still the same issue

Have moved the CAL's to the Terminal server and still the same issue. (installed remote desktop host license role)

I had to fall back to the windows 2003 terminal server so that the users can continue to work.

All this running on ESXi 4.1 on Dell Blade hardware.
Virtual VMXNET 3 network cards (10gb)

i do get the attached error on licensing manager under review configuration

any suggestions ?
Remote-Desktop-Error.JPG
Comment
Watch Question

Disable TCP Chimney
IT super hero
CERTIFIED EXPERT
Commented:
C:\ >netsh int tcp set global chimney=disabled

in: http://technet.microsoft.com/en-us/library/gg162682(v=ws.10).aspx

Author

Commented:
Thanks for the suggestions...

i did as suggested but still doing the same

check the attached file

Is there anything else that needs disabled ?
VIP-Terminal-Issues.JPG
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooter
CERTIFIED EXPERT

Commented:
Good morning Zniper,
  First thought -- When you installed the License Server, what scope did you give it?  (In the past, I've needed to promote myself to Enterprise Admin during the install so that I'd have sufficient permissions to publish the License Server in AD.  This might not be necessary, depending on your scope, and policies.  No one runs with Schema or Enterprise Admin on a routine basis.)

  Second thought -- Review the configuration of the Remove Desktop Licensing Manager.  The tool specified in the link should assist you in publishing the required information in AD.  (You might need to change scope once or twice, and give yourself sufficient permissions to do so, if you don't already have them.)  This should resolve the initial error message you are receiving, and hopefully also resolve the random disconnects.
CERTIFIED EXPERT

Commented:
Check this article and see if the recommended fixes work for you:

Event ID 85 — Remote Desktop License Server Discovery
Most Valuable Expert 2014

Commented:
You didn't mention what the clients are running. If any of them are WinXP, make sure they are patched to the roof, especially the RDP/MSTSC client. That is a deliberate, optional, separate install.

Author

Commented:
Jimpen i did run all the sessions as a test from my win 7sp1 laptop and it disconnected.

I left it for the users to test and they have a mix of win7sp1 and winxp sp3 and still did the same issue....

Asavener i will try your suggestion and report back!

Author

Commented:
Asavener  i did what MS suggested , forced replication , restart server and still having same issue under review config in RD Licensing Manager

any other ideas ?

Check the attached file
Capture.JPG

Author

Commented:
I am wondering if this is really a licensing issue... because if no licenses available it would not let you log in....

all these profiles log in and then disconnect all at once.
Rich WeisslerProfessional Troublemaker^h^h^h^h^hshooter
CERTIFIED EXPERT

Commented:
Normal windows server would let you log in two users without making the system a Remote Desktop server.  It appears that Remote Desktop Server might give you one more connection...

Are there any messages appearing in the windows logs when the users are disconnected?

When you published, then republished the license server in AD, what scope did you use?  (IF you used the the forest scope, were you Enterprise Admin when you published/republished?)
CERTIFIED EXPERT

Commented:
Windows 2008 R2 defaults to the highest compression setting.  Can you try changing that?  Maybe to balanced?

Author

Commented:
asavener where do you change compression settings ? i can see anything on the remote desktop session host configuration ?

i think that you can only lower compression on the client side?
CERTIFIED EXPERT
Commented:
http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/87fc497a-27fd-4a76-ab59-ea5fe01c9091/

1. Logon to the Remote Desktop Services Session Host computer as an administrator
2. Start--Run gpedit.msc
3. In the left pane, under Computer Configuration, navigate to following:

Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

4. In the right pane, double-click on Set compression algorithm for RDP data
5. Select Enabled, and choose Balances memory and network bandwidth
6. Click OK to save the change

Author

Commented:
asavener it was already configured to set rdp compression algorithm to : Balances memory and netowrk bandwidth

i disabled it now and will start testing again

Author

Commented:
i see the following in event viewer

Event 4005, Winlogon

The windows logon process has unexpectedly terminated.
CERTIFIED EXPERT

Commented:
What virtualization environment are you using?

Author

Commented:
Esxi 4.1 , with 10gb iscsi , with vmxnet3 virtual nics.

Why ?

Author

Commented:
Esxi 4.1 , with 10gb iscsi , with vmxnet3 virtual nics.

Why ?
CERTIFIED EXPERT

Commented:
Can you try using the E1000 NIC?

Author

Commented:
asavener i did that just now and same issue....

iam sure we missing something here. or something stupid causing issue :S

same hardware and server 2003 works :S

Author

Commented:
any other ideas?
CERTIFIED EXPERT

Commented:
I think my next suggestion is to install Wireshark, run a capture, and see if you can spot any reset (RST) packets.
Commented:
The issue was resolved in some way.

Here's what i did.

Created a new virtual server with thick disk (c only) installed server 2008R2 STD  , install .net feature , Run windows update , join the machine to domain and install anti virus.

it is working now :S but still thinking it was the thin disks on the old server causing it.

thanks a million for all the help and suggestions. much appreciated

Author

Commented:
There was a load of changes made so not a clear understanding as to what caused the issues.