Unable to resolve DNS behind Cisco ASA 5505

Posted on 2012-08-13
Last Modified: 2012-08-18
Hello all

I am unable to resolve DNS behind my Cisco ASA 5505. Windows server 2008 r2 is setup as the dhcp server and external dns server is configured as forwarders. Here are my asa config. Anyone know where the problem could be?

Result of the command: "sh conf"

: Saved
: Written by enable_15 at 21:39:48.557 UTC Sun Aug 12 2012
ASA Version 8.3(2) 
hostname XXXFW
domain-name xxxxxx.local
enable password yNew3bgX2gTfsqf/h2uCL encrypted
passwd 2KqQnbfwNI.2KYOU encrypted
name proxy
interface Vlan1
 nameif inside
 security-level 100
 ip address 
interface Vlan2
 nameif outside
 security-level 0
 ip address 81.XXX.XXXX.XXX 
interface Vlan3
 nameif dmz
 security-level 50
 ip address dhcp 
interface Ethernet0/0
 switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
boot system disk0:/asa832-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name xxxxxx.local
object network obj- 
object network obj- 
object network obj- 
object network obj- 
object network obj- 
object network obj_any 
object network PPTP-server 
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list xxxxvpn_splitTunnelAcl standard permit 
access-list inside_nat0_outbound extended permit ip 
access-list inside_nat0_outbound extended permit ip 
access-list outside_1_cryptomap extended permit ip 
access-list outside_access_in extended permit tcp any host eq 3389 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool xxxxpool mask
ip local pool xxxx10.26.0.150- mask
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-634.bin
no asdm history enable
arp timeout 14400
nat (inside,any) source static obj- obj- destination static obj- obj- unidirectional
nat (inside,any) source static obj- obj- destination static obj- obj- unidirectional
object network obj-
 nat (inside,outside) static interface service tcp 3389 3389 
access-group outside_access_in in interface outside
route outside 81.XXX.XXX.XXX 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto ipsec df-bit clear-df outside
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer xx.XXX.XXX.XXX 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
dhcpd address inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy xxxxxinternal
group-policy xxxxxxxattributes
 wins-server value
 dns-server value
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value xxxxx_splitTunnelAcl
 default-domain value xxxxx.local
username attila password Nc7VToimLfa3Cxth encrypted privilege 0
username attila attributes
 vpn-group-policy xxxxx
username knkl password Hb.4ZNcTg6Ketq/w encrypted privilege 0
username knkl attributes
 vpn-group-policy xxxxx
username dach password xSyTYr0x4VCsHEv0 encrypted privilege 0
username dach attributes
 vpn-group-policy xxxxx
username oyvind password oRUppDFe.1zqh7KY encrypted privilege 0
username oyvind attributes
 vpn-group-policy xxxxx
username hagj password rbDKy3hAw01uJJjr encrypted
username hagj attributes
 vpn-group-policy xxxxxx
username kare password wOWJstV5SXfLCARX encrypted privilege 0
username kare attributes
 vpn-group-policy xxxxxx
username xxxxxpassword SQumpZUsgPFi91GI encrypted privilege 0
username xxxxxattributes
 vpn-group-policy xxxxxx
tunnel-group xxxxxtype remote-access
tunnel-group xxxxxxgeneral-attributes
 address-pool xxxxx
 default-group-policy xxxxxx
tunnel-group xxxxxxipsec-attributes
 pre-shared-key *****
tunnel-group type ipsec-l2l
tunnel-group ipsec-attributes
 pre-shared-key *****
policy-map type inspect dns preset_dns_map
  message-length maximum 512
prompt hostname context 
 profile CiscoTAC-1
  no active
  destination address http
  destination address email
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily

Open in new window

Question by:Oeyhope
    LVL 1

    Expert Comment

    try to add a service policy in ASDM for all the traffic and make sure you are inspecting DNS ,
    dns packet should come from your inside interface and go outside and be statefully inpect to permit the dns answer back without the need of an access-list in the outside interface.

    use the monitoring tab and see the real time log , filter by the ip address or the dns protocol , and try to see if the packet is going through your asa to the internet .
    LVL 57

    Expert Comment

    by:Pete Long
    Yeah you have a DNS policy map but you have not got it applied?

    issue the following commands

    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny  
      inspect sunrpc
      inspect xdmcp
      inspect sip  
      inspect netbios
      inspect tftp
      inspect icmp
      inspect ipsec-pass-thru
      inspect ip-options
    service-policy global_policy global

    Author Comment

    Thank you for trying to help. unfortunately the commands did not fix the issue :(

    Do you have any other tips?

    Accepted Solution

    Adding the following command fixed the issue:

    object network obj_any
    subnet  --> You can replace 0/0 with your internal subnet.
    nat (inside,outside) dynamic interface

    Author Closing Comment

    the command fixed the issue.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Suggested Solutions

    Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
    Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now