?
Solved

Cannot join macpro to AD domain

Posted on 2012-08-13
6
Medium Priority
?
3,339 Views
Last Modified: 2012-08-16
I get the error message. Unable to add server. Node name wasn't found (2000).

There are other macpro's and imacs on this AD domain. I just have this one machine that I cannot join to the domain. Any suggestions?
0
Comment
Question by:Gelly77
  • 4
  • 2
6 Comments
 
LVL 13

Expert Comment

by:Xaelian
ID: 38289079
Hi this seems to resolved the same problem I had.

1) Boot to Recovery Mode (Hold command-R on boot)

2) Select Disk Utility and do a Repair Disk Permissions.

3) Restart after disk permissions repair is complete

4) Setup Active Directory without issue.


Note: I tried to repair disk permissions while logged in under user under Disk Utility in Applications however this did not seem to fix my issue.  There must be a file open when logged in that cannot have it's permissions changed that is causing this issue with Active Directory setup.  The question is what file causes the issue and what changed it's permissions? Maybe an update to the OS on a software update??? who knows.

Hope this help anyone having a issue with "Node name wasn't found" error.
0
 

Author Comment

by:Gelly77
ID: 38300315
This problem is definately related to Lion. This macpro is a machine that didn't have any data on it so I wiped the hard drive and installed Snow leopard....I was able to join the domain. I then updated to Lion. Now I get a message at the log in screen that says network account unavailable, but once logged in with local admin account is shows the macpro is on the domain. I cannot log in using any network accounts. I am going to try the repair permissions option to see if that does anything...will update after.
0
 

Author Comment

by:Gelly77
ID: 38300443
OK so i did the repair permissions and still no access to network accounts. I am scared to remove it from the domain and put it back because it may not come back. Any suggestions?
0
Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

 
LVL 13

Accepted Solution

by:
Xaelian earned 2000 total points
ID: 38300469
Can you try the following?


1.set the client's time to the network time from the windows server
2.deleted the computer account off from the Active Directory
3.restart the Mac client!

Also can you verify this?

Do you have anything other than letters, numbers, and underscores/dashes in the OS X machine's name? If so, you'll have to remove them before binding to AD. Also, you should make sure that the name is 16 characters or less
0
 

Author Comment

by:Gelly77
ID: 38301637
Changed the time, deleted from AD, restarted....nothing changed. The computer name consists of 4 letters - nothing else.
0
 

Author Comment

by:Gelly77
ID: 38301682
IT'S WORKING!!!

Ok, so I reset the time AGAIN and deleted the account off AD AGAIN. Then I unbinded it and then binded it again. Restart between each step. Now it's working.

Thanks for the help!!!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
A professional opinion on which Apple product to buy, and a tidbit about the WWDC.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
As many of you are aware about Scanpst.exe utility which is owned by Microsoft itself to repair inaccessible or damaged PST files, but the question is do you really think Scanpst.exe is capable to repair all sorts of PST related corruption issues?

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question