?
Solved

the server cannot fulfill the request

Posted on 2012-08-13
23
Medium Priority
?
2,191 Views
Last Modified: 2012-11-10
I have one remote user that is running Office 2011 on a Mac which is connected to my exchange server in the corporate office.  Every time he sends an email with attachment greater than 3 megs he gets the following message:  "Http error. The server cannot fulfill the request."
 
What do I do to resolve this?
0
Comment
Question by:tips54
  • 13
  • 9
23 Comments
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38288746
Check if restart of IIS does help fix this issue for you.

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38288784
I have rebooted my server several since this error.    do you think this issue is on the server?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38288822
Seems to me yes. Let me research on this.

Regards,
Exchange_Geek
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
LVL 8

Expert Comment

by:databoks
ID: 38288824
Are you sure that the Exchange can send data higher that 3 MB attachments?
What happens when another user tries to send exactly the same Email, Exactly the same Attachments? When you have tried this and posted the result here we can see whether this is a PC or server problem.
0
 
LVL 33

Accepted Solution

by:
Exchange_Geek earned 1350 total points
ID: 38288902
Here is what one of my friends passed his notes on this issue.


1) Take a backup (copy) of ApplicationHost.Config (Should be under Inetsrv\Config) and web.config (Should be at installation directory C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\ews)
2) Instal the Administration pack on the Exchange 2010 CAS servers - link

3) Go to IIS Manager -> Choose EWS -> Look for Request Filtering
4) We then double clicked on Request filtering and modified the “Maximum allowed content Length” to value - 83886080 (converts to 80Megs)
5) In IIS Manager -> Choose EWS -> Configuration Editor -> Locate maxRequestLength and change the value to 81920 (converts to 80 Megs)
6) Locate web.config at the following location (C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\ews\web.config)

Find the entries for maxReceivedMessageSize and ensure the value is in Bytes (83886080).  

7) We did an IISRESET and verify results.

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289201
Internally I can send an email 12Meg attachment with no problem.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289221
Check if you can modify to a bigger size, that'll help.

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289279
Will do Echange_geek.  
This is Exchange 2007 by the way.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289303
Is it on W2k8 or W2k3?

If it is IIS6 - try this resource kit - link

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289371
it's on SBS 2008
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289392
Perfect so IIS 7 link should work

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289440
After installing the admin pack I don't see EWS in IIS Manager. what am I missing?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289474
Do you see that under SBS Web applications?

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289559
I do.  Under request filtering which Tab do I go under?  under the file name tab or Hidden segments when I Edit the feature settings the Max. Content setting is set to: 30000000 which is more than what you have in the notes but the user is still not able to send more than 3 megs out.  Where exactly should I be looking ?
0
 

Author Comment

by:tips54
ID: 38289563
The web.config file does not have any entries for maxReceivedMessageSize  either.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289593
Interesting,

BTW the entry that you've got is and the entry that i've suggested is written below.
30000000
83886080

Were you able to locate the following setting?
In IIS Manager -> Choose EWS -> Configuration Editor -> Locate maxRequestLength and change the value to 81920 (converts to 80 Megs)

If you can't find the RecievedMessageSize - avoid it.

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289628
I was not.  BTW: yours equals to 81 meg and mine is 30 Meg which is plenty. I just don't think i'm looking in the right place. but there's only so many tabs.
0
 

Author Comment

by:tips54
ID: 38289754
did I screw up something Exchange-geek?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 38289765
Perform an IISRESET, to check post applying the changes if something helped.

Apart from that trying to look into my docs to check which all settings you could check in order to get this working.

The above setting did help my friend fix his issue surely.

Regards,
Exchange_Geek
0
 

Author Comment

by:tips54
ID: 38289777
I did do a reset prior to the last message.  no luck.  but the thing is I Didn't change anything or knew where to change it.
0
 

Author Comment

by:tips54
ID: 38289784
Also the interesting part about this is if I log on via owa in IE I can send a 6 Meg file just fine  But the user can not using his Outlook 2011 on the Mac.  I will have him email me the file back via owa.
0
 

Author Comment

by:tips54
ID: 38352770
nothing?
0
 

Author Closing Comment

by:tips54
ID: 38587787
this is caused by Exchcange.
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses
Course of the Month15 days, 13 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question