Connecting Outlook 2010 to Exhange Using Http

Have a client with a SBS 2011. The Exchange runs fine and has Outlook Anywhere enabled with basic authentication. I can easily log into OWA account with https://mail.xxxxx.com/owa. I am trying to setup Outlook 2010 on new computer outside network with same account and following settings ...
mail server is mail.xxxx.com, username is johndoe@xxxxx.com. Under connection tab, "Connect to Exchange using HTTP" is enabled. Connection settings are https://mail.xxxx.com. Connect using SSL (no proxy server checked). Enabled on slow and fast networks, use http first. Basic authentication selected. Also under Security tab, encrypt data between Outlook and Exchange is enabled.
Error I get is "The action cannot be completed. The connection to Miscrosoft Exchange is unavailable. Outlook must be online or connected to complete this action." Any help is appreciated.
xav1963Asked:
Who is Participating?
 
Frosty555Connect With a Mentor Commented:
OWA is unrelated to Outlook Anywhere (e.g. RPC over HTTP), they are two completely different and separate technologies. Make sure you have enabled Outlook Anywhere in the Exchange Management Console.

A few things to check:

- On my server, running Exchange 2010, I have Outlook Anywhere enabled with NTLM authentication, that seems to work the best IMHO
- Your "Connect to Exchange using HTTP" setting looks correct (should be https://mail.xxxxx.com), but in Outlook 2010 the "Server" specified at the very beginning of the wizard should be the INTERNAL name of your server (e.g. theserver.mycompany.local)
- Username should be the user account in active directory.
- Under "More Settings->Security", ensure that the "Encrypt data between Microsoft Outlook and MS Exchange" is ticked, and select "Password Authentication (NTLM)" as the logon network security.

- Make sure your certificates are correct - they should be a unified communications certificate signed by a trusted authority, and they should name the internal URI, AND the external URL, AND the autodiscover URL of your exchange server. You CANNOT use a self signed certificate, period. Bad certificates are the #1 reason for weird unexplainable failures in Outlook Anywhere.

- Also, make sure autodiscover is working correctly - Outlook 2010 can automagically configure all of this stuff all by itself just by typing the email address and password in if you have autodiscover configured correctly, it's glorious.

Use the microsoft connectivity analyzer to check that everything is working. If will give you in-depth information as to what the problem is, it is especially useful for identifying problems with your certificates:

https://www.testexchangeconnectivity.com/

You MUST pass the "Outlook Anywhere" and "Outlook Autodiscover" tests. It would be good to pass the "Exchange ActiveSync" and "Exchange ActiveSync Autodiscover" tests too.
0
 
djcanterCommented:
You will need to configure RPC over HTTP.
From Outlook, open the account settings, select connectiontab, then Select 'Connect to Microsoft Exchange using HTTP' . Click Exchange proxy settings.
 on the URL line enter your domain name: mail.yourdomainname.com, oselect Connect using SSL only, and only connecto to proxy server that have this principal name in their certificate: msstd:mail.yourdomainname.com
msstd.docx
0
 
xav1963Author Commented:
That was it.... at beginning of wizard, had to use the internal server name.... thx....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.