• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3270
  • Last Modified:

not able to connect to DHCP server

I am running windows 7, and have a win 2k3 DHCP server.  I have multiple Dell swithces in my network.  
I have roughly 65 PCs, and for some strange reason, this morning, 2 PC's can't connect to my DHCP server.  I can't ping the server, I can't browse to it.  This happened 3 weeks ago and the only way I was able to resolve it is to replace the NIC with a new one.

But that can't be the solution as everytime this occures, I just replace NICs.
When checking ipconfig, I have a good IP address, default gateway and the DHCP and DNS are both correct.
I can ping any other server on my network.

I'm puzzeled what is blocking my PC to not ping and connect to my DHCP server.
On the DHCP server, I even deleted the IP address that I had on my PC.  Then I restarted my PC and it still has the same IP. I even did a /renew and it just says "an error occured while renewing interface local area connection: unable to contact your DHCP server. Request has timed out."

Any suggestions?

Thanks.
0
afacts
Asked:
afacts
  • 10
  • 3
  • 2
  • +2
4 Solutions
 
databoksCommented:
Can you check the Event Viewer for further details? Try disabling Firewall, Antivirus etc(even though this shouldn't be the reason).

Also when you get this error again then try to set a static IP address on the PC. This will tell whether the PC can see the DHCP after you give it a static IP address.
0
 
xDUCKxCommented:
Can you statically assign an IP to one of the problem machines and ping successfully?

Is DHCP Relay configured correctly on all hops on the switches if you're using different subnets?  

When you get an IP Address and are unable to ping, can you do a route print and verify that your Default route is correct?
0
 
MikeIT ManagerCommented:
Delete the PC's DHCP lease from the DHCP server and renew the client's IP address.  I've been running into this issue lately as well.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Brad BouchardInformation Systems Security OfficerCommented:
Try this from command prompt:

Do
IPCONFIG/FLUSHDNS

Then do
IPCONFIG/REGISTERDNS

Lastly try
NETSH INTERFACE IP DELETE

Let me know if you can connect to your DHCP now from the affected machines.
0
 
afactsAuthor Commented:
The flushdns and registerdns works fine.

The netsh interface ip delete (does not work)
I even tried using the actual IP address instead of IP (does not work)
error says "the following command was not found: interface ip delete 192.168.100.135

I will try the other suggestions now.
0
 
afactsAuthor Commented:
Not sure if this has anything to do with it?  I don't see anything else that can cause it.

Log Name:      System
Source:        e1kexpress
Date:          8/13/2012 7:59:11 AM
Event ID:      32
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      pcname.domain.org
Description:
The description for Event ID 32 from source e1kexpress cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Intel(R) 82567LM-3 Gigabit Network Connection

the message resource is present but the message is not found in the string/message table

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="e1kexpress" />
    <EventID Qualifiers="24580">32</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-08-13T14:59:11.067230200Z" />
    <EventRecordID>81709</EventRecordID>
    <Channel>System</Channel>
    <Computer>pcname.domain.org</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>Intel(R) 82567LM-3 Gigabit Network Connection</Data>
    <Binary>0000040002003000000000002000046000000000000000000000000000000000000000000000000020000460</Binary>
  </EventData>
</Event>


This error occures because it can't connect to my DHCP server, which is my DC as well.

Log Name:      System
Source:        Microsoft-Windows-GroupPolicy
Date:          8/13/2012 7:59:39 AM
Event ID:      1058
Task Category: None
Level:         Error
Keywords:      
User:          SYSTEM
Computer:      pcname.domain.org
Description:
The processing of Group Policy failed. Windows attempted to read the file \\domain.org\sysvol\domain.org\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini from a domain controller and was not successful. Group Policy settings may not be applied until this event is resolved. This issue may be transient and could be caused by one or more of the following:
a) Name Resolution/Network Connectivity to the current domain controller.
b) File Replication Service Latency (a file created on another domain controller has not replicated to the current domain controller).
c) The Distributed File System (DFS) client has been disabled.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-GroupPolicy" Guid="{AEA1B4FA-97D1-45F2-A64C-4D69FFFD92C9}" />
    <EventID>1058</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>1</Opcode>
    <Keywords>0x8000000000000000</Keywords>
    <TimeCreated SystemTime="2012-08-13T14:59:39.505248200Z" />
    <EventRecordID>81720</EventRecordID>
    <Correlation ActivityID="{4B0B8FF5-A171-437D-BB54-0204F84D0428}" />
    <Execution ProcessID="1560" ThreadID="2028" />
    <Channel>System</Channel>
    <Computer>pcname.domain.org</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="SupportInfo1">4</Data>
    <Data Name="SupportInfo2">816</Data>
    <Data Name="ProcessingMode">1</Data>
    <Data Name="ProcessingTimeInMilliseconds">31668</Data>
    <Data Name="ErrorCode">53</Data>
    <Data Name="ErrorDescription">The network path was not found. </Data>
    <Data Name="DCName">\\dc1.domain.org</Data>
    <Data Name="GPOCNName">cn={31B2F340-016D-11D2-945F-00C04FB984F9},cn=policies,cn=system,DC=amazingfacts,DC=org</Data>
    <Data Name="FilePath">\\domain.org\sysvol\amazingfacts.org\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini</Data>
  </EventData>
</Event>
0
 
afactsAuthor Commented:
so I changed IP address to static on my PC, rebooted, I also cleared the arpcahce and it worked with static IP.  I changed it back to dynamic and it still works, I can ping my dhcp server, so that's good.

On the second PC, I did the same, but it still does not work. When static, I can ping the DHCP server, but when dynamic, I can't ping the dhcp server.  I've restared, cleared the arpcahce, removed the AV program, nothing.   The windows firewall is on by default via GP, so I can't turn that off unless I turn it off for everyone, but I know it's not the firewall as it worked fine last week and I haven't made any changes to GP.

What else can I do?  Not sure how to fix this?
0
 
databoksCommented:
It is related to your NIC. What is the state of the NIC on boot? It is either disabled or enabled. Sometimes I can't get a address too so I disable and enable the NIC and the problem is solved.
0
 
databoksCommented:
All right. Good, good, good, good for PC1.
Check the event viewer on the second machine? Is pc1s hardware identical to pc2?
Also if that is not the case see event viewer on this machine too.

Check the event viewer on the DHCP server.
Try also to reserve anIP on the DHCP server
For PC2.
0
 
afactsAuthor Commented:
I already tried to disable and enable the NIC, still does not work.
I did repair, which resets the arp cache, DNS, etc... and that didn't work either.
The hardware are different on both machines.

I will check the event viewer next.
0
 
afactsAuthor Commented:
Not sure what this is about, but this was on the DC server, and it was referring to my PC.
I do not see anything referring to the other, second PC.

Event Type:      Error
Event Source:      MRxSmb
Event Category:      None
Event ID:      8003
Date:            8/13/2012
Time:            8:00:25 AM
User:            N/A
Computer:      EDEN
Description:
The master browser has received a server announcement from the computer mypc that believes that it is the master browser for the domain on transport NetBT_Tcpip_{EF81B9E4-1129-47E8-. The master browser is stopping or an election is being forced.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 03 00 4e 00   ......N.
0008: 00 00 00 00 43 1f 00 c0   ....C..À
0010: 00 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0
 
afactsAuthor Commented:
application log and all other logs look good on the server, will check the client next.
0
 
afactsAuthor Commented:
On the client, I see this in the system log:

Event Type:      Error
Event Source:      Dhcp
Event Category:      None
Event ID:      1002
Date:            8/13/2012
Time:            11:34:45 AM
User:            N/A
Computer:      PCname
Description:
The IP address lease 0.0.0.0 for the Network Card with network address 001E4F50E074 has been denied by the DHCP server 192.168.100.50 (The DHCP Server sent a DHCPNACK message).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


I see this numerous times over and over again.
0
 
xDUCKxCommented:
Did you image these two machines with the same Image clone?  Try updating the NIC driver.  I would agree that this looks like a hardware issue at this point.

(The browser (MRxSMB) error is moot since you don't have a connection to the network.  You can ignore it.)
0
 
afactsAuthor Commented:
I figured it out!!!!!!!!!!!!!!!!

In my DHCP server, I noticied there were few entries that had an explimation mark, and in the name, it had "badd_address", and it did have an IP address and MAC.
So I deleted them.

Then I went to the client, did a:
ipconfig /release

Waited a few seconds, did a ipconfig /renew and it didn't work as it couldn't connect to the DHCP server.

So I waited a few seconds and I noticied that it received connectivity, so it tried again apparently and obtained an IP address, a differrent IP address then before, as I had deleted the old address from the server when the PC was turned off.

With the new IP address, everything works fine, can ping my DHCP, and I restarted the PC just to make sure and it's still working, so that's the rest of the story.

I guess when it happens again, I need to figure out why the "bad_address" occures on my DHCP server.......
0
 
afactsAuthor Commented:
LOL, exclimation mark  hmm......  this keyboard.
0
 
afactsAuthor Commented:
Well, that fixed it temporarily, but the same issue has happened again, so there's something wrong with my DHCP server, as it's been 4 PCs now in 2 days.

Any advise on what I should be looking at?
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 10
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now