We help IT Professionals succeed at work.

Exchange 2003 Outlook 2010 - Free busy data showing 2 months for SOME users with GPO set for 12 months

Medium Priority
1,080 Views
Last Modified: 2012-09-22
Hello all,

Our organization has 2 Exchange 2003 servers at our corporate office and 3 additonal Exchange 2003 servers at remote offices (1 each).

All had been working fine through Windows 7 upgrade and upgrade to Office 2010.  Now we are seeing that some users (varies on which EX server mailbox is on) free busy data is not showing up correctly.

Tried the cleanfreebusy switch on client(s) - did not fix the issue

Cannot find anything else that points me in the right direction short of calling MS directly.

Any help appreciated.
Comment
Watch Question

Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Is the GPO applied to machines successfully ?

If its so it will make the changes to Free busy for 12 months.

- Rancy

Author

Commented:
The GPO applies successfully.
The time on the clients shows as 12 months and 15 minutes.  Boxes are grayed out (disabled) so end user cannot change the duration.

Author

Commented:
let me re-phrase that.  The time of 12 months shows applied, but client still allows you to view 2 motnths or less.
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
As you have the policy for 12 month it shows always 1 month back and rest in advance by default.

Maybe the FBfolder is corrupted then :(

- Rancy

Author

Commented:
Good thought
I just dismounted Public folder store and am running ISINTEG check on it.

I will let you know what happens
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Sure let me know if that doesnt help .. Also can try to run
Outlook /cleanfreebusy and check if that would help with one user.

- Rancy

Author

Commented:
Ran ISINTEG on the db and found a few issues.  All were repaired.

Still same issue with free busy time as stated initially.

Have tried the cleanfreebusy switch starting outlook.  Does not seem to fix the issue.
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Do big is your PF database ?
as said could be that FB folder has issue .

- Rancy

Author

Commented:
PF DB is 1.95GB
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Not sure but if something like this will help

$warningpreference = "SilentlyContinue"

http://sus42.wordpress.com/2010/12/30/start-the-microsoft-exchange-2010-shell/
Now we look a litte bit further. The variable $warningpreference defines what happens if a script uses the write-warning cmdlet in order to make some output. If you set this variable to the value of silentlycontinue the output is suppressed. The default of this variable is Continue whitch means that warningmessages are displayed in yellow color on the console. If you want to get more details on preference variables you can read the PowerShell help
- Rancy
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Sorry the last post was for some other post .... my miss

What do you see when you view FB from OWA\Webmail ?
Is there a possiblity of checking with Outlook 2003 or Outlook 2007 to check if the issue isnt with Outlook ?

- Rancy

Author

Commented:
I loaded a machine with XP and Office 2003
Same Issue

OWA has the same result.  Nothing past 10/1

The scarier part is that I originally thought it was defaulting to the 2 month setting for publishing free busy.  BUT, it has not moved past 10/1 and we are almost to the end of August.

I have went back through all permissions etc....all pub folders are showing that they are synch just fine....
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
I guess some issues with the Free+Busy PF system folder.

Give me sometime will try to get down some data and then share with you.

- Rancy
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013
Commented:
Run Gpmc and check if the FB policy is being applied .... also try to manually try to configure an Outlook for 12 months and run

Outlook /Cleanfreebusy and open Outlook.

- Rancy

Author

Commented:
Checked random users (both affected and non-affected)  FB policy is still applying.

Cleanfreebusy works but does not correct the issue.

Author

Commented:
also ran gpresult to verify policy is being offered and applied.

Author

Commented:
UPDATE:

Loaded a machine again with WIndows 7 and Office 2003 Pro.

Logged in an affected user and opened Outlook.  (realized that last time I did this I did not wait past the 15 minute update window).  Calendar populates free busy time published.

go back to machine with Office 2010 and free/busy goes back to not displaying except 60 days or less.

Could this be a compatibility issue with Outlook 2010 and Exchange 2003 SP2 ?
Manpreet SIngh KhatraSolutions Architect, Project Lead
CERTIFIED EXPERT
Top Expert 2013

Commented:
Assess how Outlook 2010 works with different versions of Exchange Server
http://technet.microsoft.com/en-us/library/cc178996.aspx

Ohk lets give one more thing a try ... just give me few mins will send another update.

- Rancy
Clean Free Busy worked for some clients.

Turns out there was a hotfix that could only be obtained by contacting MS.

Rollup of KB2589404, 2596485, 5289415
All of which were installed individually, but after applying this new HotFix issue was totally resolved.

Author

Commented:
Contacted Microsoft and opened support case.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.