• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 727
  • Last Modified:

OWA-FBA missing

We were having problems with our OWA website not displaying the normal logon page. It would bring up an authentication box separate from the page. We were able to authenticate. At the same time, we started having problems with our users and free/busy, shared calendaring, public folder items. This all pointed to the autodiscover record.

I was able to delete the OWA virtual directory using Exchange Management Shell. I then recreated the OWA virtual directory using Ex Mgmt Shell. This has resolved the issue with the OWA site. It now correctly displays the page. However, Autodiscover still did not workproperly.

When I went to the /Autodiscover website URL, it brought up a message "server error in application OWA-FBA". I thought I would be able to reinstall that virtual directory as well, but have not been able to find instructions on how to reinstall OWA-FBA. So as it stands OWA is working, but Autodiscover is not working.

Can anyone please tell me how to reinstall the OWA-FBA virtual directory in IIS on Exchange 2007?
0
Felicia King
Asked:
Felicia King
  • 7
  • 6
  • 3
3 Solutions
 
Exchange_GeekCommented:
Re-installing any virtual directory is simple, use the following link

http://my.opera.com/RavenOverride/blog/2009/06/17/how-to-recreate-all-virtual-directories-for-exchange-2007

However, what makes you think you've broken Autodiscover only?

Regards,
Exchange_Geek
0
 
Felicia KingAuthor Commented:
The OWA-FBA virtual directory in IIS is gone and Autodiscover relies upon that. When I browse using IE to the /Autodiscover page, it produces an error complaining about OWA-FBA. I think that the rest of OWA is working because I have tested the website function and it works properly. I was able to deleted and recreate those virtual directories through the Exchange Mgmt Shell. I will try the items in the link you provided this morning. Thanks.
0
 
Exchange_GeekCommented:
Perfect, waiting for your feedback.

Regards,
Exchange_Geek
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Felicia KingAuthor Commented:
I was able to delete and recreate the Autodiscover virtual directory properly. It is showing the proper URL now also. However, when I browse to that URL using IE, it prompts for a logon box the same way that the /OWA site did before that was fixed.
It's clear that /Autodiscover is reliant upon the virtual directory for OWA-FBA, but I cannot find a way to recreate that. When I browse to /Autodiscover, get the prompt to login, and then login, it is still failing saying that the application doesn't work because OWA-FBA is missing.

Furthermore, OWA-FBA used to show up in Exchange Management->ServerConfig->ClientAccess under the OWA tab. Now the only thing there is the OWA site.
Do you know of a way that I can recreate the OWA/FBA virtual directory? It used to exist in IIS under Sites. It was at the same level as Default Web Site.
0
 
Exchange_GeekCommented:
Never heard of any such virtual directory, here is the link that shows all the necessary virtual directory that should be in-place for E2007

Yes, what was in-place was to have FBA in-place but that was more of an authentication for legacy virtual directory - a setting that was kept in place on E2k7.

Ref: http://www.fixkar.com/articles/kb/1070/

Regards,
Exchange_Geek
0
 
MegaNuk3Commented:
Are you running SBS2008?

What happens if you try and connect to:
https://<Internal_CAS_Name_on_Certificate>/autodiscover/autodiscover.xml

From a workstation vs. from the CAS server itself?

Ensure you have no redirection on the autodiscover virtual directory
0
 
Felicia KingAuthor Commented:
The Exchange server is 2008 x64 standard, not SBS.  What happens from any computer when I try to access that URL is that a logon prompt box pops up. If I authenticate through using the username and password of a mailbox, it proceeds to tell me that the website is not working properly. See attached printout of the results.
401AutodiscoverUnauthorized.pdf
0
 
Exchange_GeekCommented:
Is the account locked with which you are accessing this mailbox, please check.

Regards,
Exchange_Geek
0
 
MegaNuk3Commented:
Try step 5 from my article: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_4962-7-Steps-to-AutoDiscover-Heaven.html 

If that fails to work then reset your autodiscover as per my article
0
 
Felicia KingAuthor Commented:
I've tried it from three different PCs with three different user accounts. All are unlocked and all have mailboxes. It prompts the logon box for each one. What is supposed to happen when a person browses to an Exchange server /Autodiscover URL that is working?
0
 
Exchange_GeekCommented:
you should find a response similar to

?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.lab.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="20:34:04.4687500" Id="722291282">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>

Regards,
Exchange_Geek
0
 
MegaNuk3Commented:
You should get:
"error code 600 = invalid request"

When it is working properly.

Make sure windows and basic auth are set on the autodiscover VD as per: http://technet.microsoft.com/en-us/library/gg263433(v=exchg.80).aspx
0
 
Exchange_GeekCommented:
Please check autodiscover application pool is pointing to MSExchangeAutodiscoverAppPool

Regards,
Exchange_Geek
0
 
Felicia KingAuthor Commented:
Authentication methods on Autodiscover virtual directory are as specified in the tech article referenced above. Yes, verified that MSExchangeAutodiscoverAppPool is the app pool that the virtual directory uses. I checked in Manage App-> Advanced, and it shows the correct pool as the application pool.
There are no physical path credentials specified. Logon type for the physical path credentials is clear text.
0
 
Exchange_GeekCommented:
Do you have an A Record or SRV that points to Autodiscover.Domain.com

Regards,
Exchange_Geek
0
 
Felicia KingAuthor Commented:
I have been unable to get the Autodiscover page to show correctly, meaning that it doesn't show error code 600 like it should. But the users' problems have gone away and Outlook-based email connectivity and webmail connectivity are working properly again.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 7
  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now