Windows XP machine can't access file shares (on workgroup)

I removed a Windows XP machine from a non-existent domain to a Workgroup and I can ping the "server" via IP and name, but I cannot access the shared folders.
All other PC's in the workgroup can access them fine.

When I try to browse the WORKGROUP, there is an error message.

I've checked the WINS and NetBIOS settings... all normal.  I've done ipconfig /flushdns.
I've checked file sharing and firewall rules.

Please help!
LVL 8
Reece DoddsAsked:
Who is Participating?
 
Ravi AgrawalCommented:
You did not mention windows 7 in the equation.

On the Windows 7 apply the attached registry hack. You will need administrative privileges for this.

You will need to rename the txt file to reg before it can be imported to the windows 7 registry.

Reboot the Windows 7 machine.

Ravi.
LSA-default-w7.txt
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
What is the error message?
0
 
Reece DoddsAuthor Commented:
When trying to access the server for the shares:
\\192.168.1.1 is not accessible.  You might not have permission to use this network resource.
Contact the administrator of this server to find out if you have access permissions.

The specified server cannot perform the requested operation.

When trying to browse the workgroup it says the same thing except substitute \\192.168.1.1 with Workgroup
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Miguel Angel Perez MuñozCommented:
Check service "server" is running on both computers.
0
 
Ravi AgrawalCommented:
Have a look at the subnet mask. By default it should be 255.255.255.0

Is it the same on other Computers. This error is also returned when the subnet mask is not the same as other members of the Workgroup.

Seems like a permissions issue to me. Go to Control Panel > folder options > View tab > Advanced Settings > Use simple file sharing. Make sure it is checked.

Ravi.
0
 
Reece DoddsAuthor Commented:
the "server" service is running, SFS is checked and the WORKGROUP and subnet are the same as the other PC's (and server).

It can see it's own "Shared Documents" folder and printers by browsing to \\Courtney-PC and \\192.168.1.11 and \\127.0.0.1
0
 
Reece DoddsAuthor Commented:
Is there a specific setting on a Windows 7 PC that must be enabled/disabled for Windows XP machines to access its network shares?
0
 
Reece DoddsAuthor Commented:
OK, here's something frustrating...

I've just created a share on one of the other Windows7 PC's and this problematic XP machine can access its share fine (using either IP or UNC name).

Is there a way to do a full reset of all DNS, NetBIOS and UNC naming caches? Or something like that?
0
 
Reece DoddsAuthor Commented:
Perfect!

Can you explain what that registry edit actually did?

Cheers
0
 
Ravi AgrawalCommented:
No

Sorry, its just a fix I found somewhere on some other forum

Ravi.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.