[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4437
  • Last Modified:

XAMPP: Another FTP daemon is already running.

Hi,

I just installed XAMPP for linux 1.8.0 on my below linux server:

[root@mtatb01 ~]# uname -a
Linux mtatb01.test.du.ae 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:54:53 EST 2006 i686 athlon i386 GNU/Linux

Open in new window


XAMPP works fine now except the ProFTPD is not working. Each time i tried to start the xampp i got a message :
XAMPP: Another FTP daemon is already running.

Open in new window

here is the full output of stop/start command

[root@mtatb01 ~]# /opt/lampp/lampp stop
Stopping XAMPP for Linux 1.8.0...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.

[root@mtatb01 ~]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.0...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.

Open in new window


it seems there is another FTP server is installed in the server. i want to use the XAMPP ProFTPD  which i installed. I’ve googled this trouble extensively for over an hour and I haven’t found a reasonable solution. Firstly, should I be worried about this? If so, then the common solution seems to be using ps aux | grep ftp in order to find the process using the FTP and kill it, but I’m unable to kill FTP for some bizarre reason. Please advise how to find and remove any other instance already installed and force linux to use only the ProFTPD  packed with XAMPP?

waiting for prompt help as it is stopping me from proceeding further.
Zak
0
zakwithu2012
Asked:
zakwithu2012
1 Solution
 
Sergey KolesnikCommented:
Seems like that some application already took port 21 (or port you've configured as FTP port during XAMPP installation/configuration)
You can find it using following command: netstat -pan |grep 21
In the right column you'll see pid/program name which listens for port 21
Please do not forgot to change the port if you've setup another one.
0
 
zakwithu2012Author Commented:
netstat -pan |grep 21 :
[root@mtatb01 /]# netstat -pan |grep 21
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      2853/xinetd         
unix  2      [ ]         DGRAM                    3213   1162/udevd          @udevd
unix  3      [ ]         STREAM     CONNECTED     2175236 3117/dbus-daemon-1  /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     2175235 9528/cupsd          
[root@mtatb01 /]# 

Open in new window



service --status-all :
[root@mtatb01 /]# service --status-all 
acpid (pid 2792) is running...
Usage: /etc/init.d/adminagent { start | stop | restart | start_monitor | stop_monitor | start_logger | stop_logger | start_sdap | stop_sdap }
anacron is stopped
atd (pid 2923) is running...
auditd is stopped
Configured Mount Points:
------------------------

Active Mount Points:
--------------------
hcid is stopped
sdpd is stopped
hidd is stopped
cpuspeed is stopped
crond (pid 2873) is running...
cupsd (pid 9528) is running...
cups-config-daemon (pid 3131) is running...
dc_client is stopped
dc_server is stopped
Device not specified in /etc/sysconfig/diskdump
usage: /etc/init.d/dkim-filter { restart | start | stop }
gpm (pid 2863) is running...
hald (pid 3142) is running...
httpd is stopped
ipmi_msghandler module not loaded.
ipmi_si module not loaded.
ipmi_devintf module not loaded.
/dev/ipmi0 does not exist.
Firewall is stopped.
irattach is stopped
irqbalance (pid 2637) is running...
mdmpd is stopped
dbus-daemon-1 (pid 3117) is running...
/etc/init.d/microcode_ctl: reading microcode status is not yet supported
rndc: connect failed: connection refused
Server address not specified in /etc/sysconfig/netdump
netplugd is stopped
Configured devices:
lo eth0 eth1 eth2 eth3
Currently active devices:
lo eth0 eth1
+--o nsrexecd (2932)
NetworkManager is stopped
Shutting down NFS mountd: rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped
rpc.statd (pid 2669) is running...
nscd is stopped
ntpd is stopped
USAGE: OVCtrl start|stop|restart|START|STOP|enable|disable
 OVPA status:
    Running scopeux               (OVPA data collector) pid 3026 
    Running midaemon              (Measurement Interface daemon) pid 3012 
    Running ttd                   (ARM registration daemon) pid 3003 

 OVPA Server status:

    Running ovcd                  (OV control component) pid 3072 
    Running ovbbccb               (BBC5 communication broker) pid 3080 
    Running coda                  (perf component) pid(s) 3378 
       Configured DataSources(3)   SCOPE
                                   CODA
                                   FMPMCR

    Running perfalarm             (alarm generator) pid(s) 3067 
OVPA DSI logging process status:
    The following DSI logging processes are running:
                            PID  LOGFILE SET & CLASS
    Running dsilog        15249  /var/opt/perf/datafiles/fmpmcr/fmpmcr wait_io -i /var/opt/perf/datafiles/fmpmcr/w

USAGE: OVTrcSrv start|stop|restart
portmap (pid 2649) is running...
Process accounting is disabled.
rpc.idmapd (pid 2700) is running...
saslauthd is stopped
sendmail: status not implemented
smartd dead but subsys locked
smbd is stopped
nmbd is stopped
snmpd is stopped
snmptrapd is stopped
squid is stopped
squid: ERROR: No running copy
sshd (pid 8878 2838) is running...
syslogd (pid 2622) is running...
klogd (pid 2626) is running...
CIM server is not running
tux is stopped
Xvnc is stopped
winbindd is stopped
xfs (pid 2904) is running...
xinetd (pid 2853) is running...
ypbind is stopped
[root@mtatb01 /]# netstat -pan |grep 21
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      2853/xinetd         
tcp        0      0 127.0.0.1:55835             127.0.0.1:46321             TIME_WAIT   -                   
unix  2      [ ]         DGRAM                    3213   1162/udevd          @udevd
unix  2      [ ]         DGRAM                    3218613 27098/netstat       
unix  3      [ ]         STREAM     CONNECTED     2175236 3117/dbus-daemon-1  /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     2175235 9528/cupsd          
[root@mtatb01 /]# service httpd status
httpd is stopped
[root@mtatb01 /]# service ftp  status
ftp: unrecognized service
[root@mtatb01 /]# ProFTPd
-bash: ProFTPd: command not found
[root@mtatb01 /]# service ProFTPd status
ProFTPd: unrecognized service
[root@mtatb01 /]# netstat -pan |grep 21
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      2853/xinetd         
unix  2      [ ]         DGRAM                    3213   1162/udevd          @udevd
unix  3      [ ]         STREAM     CONNECTED     2175236 3117/dbus-daemon-1  /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     2175235 9528/cupsd          
[root@mtatb01 /]# service xampp status
xampp: unrecognized service
[root@mtatb01 /]# service lampp status
lampp: unrecognized service
[root@mtatb01 /]# service --status-all 
acpid (pid 2792) is running...
Usage: /etc/init.d/adminagent { start | stop | restart | start_monitor | stop_monitor | start_logger | stop_logger | start_sdap | stop_sdap }
anacron is stopped
atd (pid 2923) is running...
auditd is stopped
Configured Mount Points:
------------------------

Active Mount Points:
--------------------
hcid is stopped
sdpd is stopped
hidd is stopped
cpuspeed is stopped
crond (pid 2873) is running...
cupsd (pid 9528) is running...
cups-config-daemon (pid 3131) is running...
dc_client is stopped
dc_server is stopped
Device not specified in /etc/sysconfig/diskdump
usage: /etc/init.d/dkim-filter { restart | start | stop }
gpm (pid 2863) is running...
hald (pid 3142) is running...
httpd is stopped
ipmi_msghandler module not loaded.
ipmi_si module not loaded.
ipmi_devintf module not loaded.
/dev/ipmi0 does not exist.
Firewall is stopped.
irattach is stopped
irqbalance (pid 2637) is running...
mdmpd is stopped
dbus-daemon-1 (pid 3117) is running...
/etc/init.d/microcode_ctl: reading microcode status is not yet supported
rndc: connect failed: connection refused
Server address not specified in /etc/sysconfig/netdump
netplugd is stopped
Configured devices:
lo eth0 eth1 eth2 eth3
Currently active devices:
lo eth0 eth1
+--o nsrexecd (2932)
NetworkManager is stopped
Shutting down NFS mountd: rpc.mountd is stopped
nfsd is stopped
rpc.rquotad is stopped
rpc.statd (pid 2669) is running...
nscd is stopped
ntpd is stopped
USAGE: OVCtrl start|stop|restart|START|STOP|enable|disable
 OVPA status:
    Running scopeux               (OVPA data collector) pid 3026 
    Running midaemon              (Measurement Interface daemon) pid 3012 
    Running ttd                   (ARM registration daemon) pid 3003 

 OVPA Server status:

    Running ovcd                  (OV control component) pid 3072 
    Running ovbbccb               (BBC5 communication broker) pid 3080 
    Running coda                  (perf component) pid(s) 3378 
       Configured DataSources(3)   SCOPE
                                   CODA
                                   FMPMCR

    Running perfalarm             (alarm generator) pid(s) 3067 
OVPA DSI logging process status:
    The following DSI logging processes are running:
                            PID  LOGFILE SET & CLASS
    Running dsilog        26109  /var/opt/perf/datafiles/fmpmcr/fmpmcr wait_io -i /var/opt/perf/datafiles/fmpmcr/w

USAGE: OVTrcSrv start|stop|restart
portmap (pid 2649) is running...
Process accounting is disabled.
rpc.idmapd (pid 2700) is running...
saslauthd is stopped
sendmail: status not implemented
smartd dead but subsys locked
smbd is stopped
nmbd is stopped
snmpd is stopped
snmptrapd is stopped
squid is stopped
squid: ERROR: No running copy
sshd (pid 8878 2838) is running...
syslogd (pid 2622) is running...
klogd (pid 2626) is running...
CIM server is not running
tux is stopped
Xvnc is stopped
winbindd is stopped
xfs (pid 2904) is running...
xinetd (pid 2853) is running...
ypbind is stopped
[root@mtatb01 /]# 

Open in new window

0
 
Sergey KolesnikCommented:
Please try to change following line in proftpd.conf
"servertype standalone" to "servertype inetd"

Otherwise you can add following line into your xinetd.conf: disabled = ftp
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
zakwithu2012Author Commented:
Still FTP is not working....
"/opt/lampp/etc/proftpd.conf" 45L, 1450C written                                                                                                                                                                           
[root@mtatb01 /]# vi /opt/lampp/etc/proftpd.conf

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "ProFTPD"
ServerType                      inetd
DefaultServer                   on

# Port 21 is the standard FTP port.
Port                            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            nobody
#Group                          nogroup

# Normally, we want files to be overwriteable.
<Directory /opt/lampp/htdocs/*>
  AllowOverwrite                on
</Directory>

# only for the web servers content
DefaultRoot /opt/lampp/htdocs

# nobody gets the password "lampp"
# commented out by lampp security
UserPassword zakFTP zakFTP:ntShyO/TSnXo2
#UserPassword nobody dp3r4O0ZzJKsM

# nobody is no normal user so we have to allow users with no real shell
RequireValidShell off

# nobody may be in /etc/ftpusers so we also have to ignore this file
UseFtpUsers off
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
[root@mtatb01 /]# 
[root@mtatb01 /]# 
[root@mtatb01 /]# 
[root@mtatb01 /]# /opt/lampp/lampp status
Version: XAMPP for Linux 1.8.0
Apache is not running.
MySQL is not running.
ProFTPD is not running.
[root@mtatb01 /]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.0...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
[root@mtatb01 /]# /opt/lampp/lampp restart
Stopping XAMPP for Linux 1.8.0...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.
Starting XAMPP for Linux 1.8.0...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
[root@mtatb01 /]# /opt/lampp/lampp status
Version: XAMPP for Linux 1.8.0
Apache is running.
MySQL is running.
ProFTPD is not running.
[root@mtatb01 /]# 

Open in new window

0
 
Sergey KolesnikCommented:
Have you tried to disable ftp in xinetd.conf?
Please have to restart xinetd service.
Also keep in mind, if you aren't use xinetd's ftp you should have in your proftpd.conf servertype = standalone.
0
 
theraffCommented:
I think that most of the information you need is already in the answers given, but I'm going to try to tidy this up a bit.

As said in a previous answer, you can use netcat to see what's using port 21. You can also use the lsof command, like this:

lsof -i tcp:21

However, it appears that the xinetd 'super service' is already configured to start an existing FTP daemon - either the one that you're trying to configure, or some other one. Check the following files to see how it's configured:

/etc/xinetd.conf
/etc/xinetd.d/*

If the 'correct' FTP daemon is configured in xinetd, simply restart xinetd to restart your FTP daemon.
0
 
zakwithu2012Author Commented:
please remember my target is to use xampp proftp. disable/remove any other ftp service running.

below are the output of your command, please help what to do exactly:

lsof -i tcp:21
[root@mtatb01 ~]# lsof -i tcp:21
COMMAND  PID USER   FD   TYPE DEVICE SIZE NODE NAME
xinetd  2853 root    5u  IPv4   6502       TCP *:ftp (LISTEN)

Open in new window



/etc/xinetd.conf
[root@mtatb01 ~]# vi /etc/xinetd.conf

#
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/

defaults
{
        instances               = 60
        log_type                = SYSLOG authpriv
        log_on_success          = HOST PID
        log_on_failure          = HOST
        cps                     = 25 30
}

includedir /etc/xinetd.d

Open in new window




/etc/xinetd.d/*
# default: off
# description: An xinetd internal service which generate characters. \
# The xinetd internal service which continuously generates characters \
# until the connection is dropped.  The characters look something like this: \
#   !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefg \
# This is the tcp version.


service chargen
{
        type            = INTERNAL
        id              = chargen-stream
        socket_type     = stream
        protocol        = tcp
        user            = root
        wait            = no
        disable         = yes
}

Open in new window

0
 
zakwithu2012Author Commented:
i ran this command:

[root@mtatb01 ~]# /etc/init.d/xinetd status
[root@mtatb01 ~]# xinetd (pid 2853) is running...

does it make sense if i remove xinetd totally? if yes please tell how?
0
 
zakwithu2012Author Commented:
??
0
 
zakwithu2012Author Commented:
Hi,

[root@mtatb01 ~]# /etc/init.d/xinetd status
[root@mtatb01 ~]# xinetd (pid 2853) is running...

i stopped xinetd service by this command:
[root@mtatb01 ~]# /etc/init.d/xinetd status

Open in new window


then stopped the XAMPP service

[root@mtatb01 ~]# /opt/lampp/lampp stop
Stopping XAMPP for Linux 1.8.0...
XAMPP: XAMPP-Apache is not running.
XAMPP: XAMPP-MySQL is not running.
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.
 

Open in new window


Start the XAMPP service:
[root@mtatb01 ~]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.0...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
[root@mtatb01 ~]#

Open in new window


you see... FTP works fine and i tested it. the new problem is the other XAMPP services (mySQL and Apatche) doesn't work because another software (daemon )is already running.
i want to remove daemon totally and use the XAMPP services. because daemon is conflicting XAMPP.

Any idea... experts?
0
 
zakwithu2012Author Commented:
correction:

i stopped the xinetd by this command:

[root@mtatb01 ~]# /etc/init.d/xinetd stop
0
 
LinuxGuruLinux Server AdministratorCommented:
Can you please try the following?

/etc/init.d/xinetd restart

Open in new window


Now kill the process listening on port 21 using the following command.

fuser -k -n tcp 21

Open in new window


Now restart lampp

/opt/lampp/lampp restart

Open in new window


Cheers!!!
0
 
zakwithu2012Author Commented:
Hi,
i managed to  start ProFTPD, however the other two xampp services mysql & apatche refuse to start. i got the below:

XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.

[root@mtatb01 ~]# fuser -k -n tcp 21 
here: 21
21/tcp:               7307
[root@mtatb01 ~]# /opt/lampp/lampp status
Version: XAMPP for Linux 1.8.0
Apache is not running.
MySQL is not running.
ProFTPD is not running.
[root@mtatb01 ~]# /opt/lampp/lampp restart
Stopping XAMPP for Linux 1.8.0...
XAMPP: XAMPP-Apache is not running.
XAMPP: XAMPP-MySQL is not running.
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.
Starting XAMPP for Linux 1.8.0...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

Open in new window


how to force Linux to stop the other confilicting applications?
or
how to force Linux to give priority to one application over the other? i believe there should be a configuration file which shows all the applications sequences.

Any idea?
0
 
zakwithu2012Author Commented:
help please.


hi admin,
please share this post among related zones.

thanks
0
 
zakwithu2012Author Commented:
help.
0
 
joolsCommented:
Hi I have posted a response in your other Q

try:

Did you stop ftp, apache and mysql on the other Q...
# chkconfig ftpd off
# chkconfig httpd off
# chkconfig mysqld off
# for i in xinetd httpd mysqld
do
service $i stop
done
0
 
Tlexander GuoCommented:
Quite interesting:

chkconfig: command not found


shicheng@meangenemachine2:~/software$ chkconfig
chkconfig: command not found
shicheng@meangenemachine2:~/software$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:        15.10
Codename:       wily
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now