We help IT Professionals succeed at work.

Outlook 2007 add-in error windows terminal server 2003

Jubal1234
Jubal1234 asked
on
Hi All,

Situation:
Network with 3 w2003 Terminal servers running Office 2007. By using load balancing the users are designated to the least loaded server. So everytime they log in they can be designated to different servers.

When starting Outlook users get the error that Outlook cannot execute an add-in. It doesn't say which add-in. Eventviewer doesn't either. After clicking OK Outlook starts normally.

The strange thing is: I only get this error once. When I stop/start Outlook the error isn't shown a second time. If I log off and log on again to the same terminal server, the error isn't shown a second time.
But, if I log on to a different terminal server, the error is shown again. Then it will not appear again untill I log on to a different server.

Sounds like something in my roaming profiles ?

Disabling the Add-ins doesn't solve the issue. Even with all add-ins diabled the error occurs the moment I switch terminal server.

Any ideas or advice ?
Cheers,
Gerard Verbruggen
Comment
Watch Question

Sajid Shaik MSystem Admin
BRONZE EXPERT

Commented:
Installing the Outlook Add-In on Terminal Server





Terminal Server is a Windows environment in which users can make a connection to a central server and access Outlook on that server instead of their desktops.
•Before installing the Add-In on a Terminal Server, ensure that no one logged into the server is currently using Outlook. Outlook cannot be open during the Add-in installation.
•Users must install the Add-In under their own profiles.

Users who are not administrators on the Terminal Server may see an error when installing the Add-In that says policies are set to prevent this installation. To work around this error, you can add a registry entry under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\.
 
To add the registry key
 1.Locate or create the registry key HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer.
2.Right-click Installer, then click New > DWORD Value.
3.Name the value DisableMSI.
4.Right-click DisableMSI, then click Modify and ensure the Value data is 0. (For more information about this registry value, refer to the MSDN article DisableMSI.)


see the article

http://kb.globalscape.com/KnowledgebaseArticle11053.aspx

all the best

Author

Commented:
Thanks for your reply: the add-ins installed are all add-ins that were installed during the installation of Office. There are no specific other add-ins. Or does the user need to remove these default add-ins and then add them again ?

Cheers,
Gerard
Sajid Shaik MSystem Admin
BRONZE EXPERT

Commented:
try removing and adding user again

then update the office with latest patches..

all the best
Sorry for the late response: Was away for a couple of days.

Without doing anything the problem seems to be gone..... On all terminal servers for all users....

If this returns I will reopen this thread.

Cheers,
Gerard

Explore More ContentExplore courses, solutions, and other research materials related to this topic.