• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2413
  • Last Modified:

Mount.CIFS - Unable to mount to share - Need example

I just installed CIFS from the Debian package directory. When I look at the help, it looks like the mount command starts with mount.cifs <remotetarget>...etc.. I just cant seem to get the command working. Can anyone help me?

I have a Windows 7 share I am trying to mount. Is there anything I need to do on my Windows side as well?

Usage:  mount.cifs <remotetarget> <dir> -o <options>

Mount the remote target, specified as a UNC name, to a local directory.

Options:
        user=<arg>
        pass=<arg>
        dom=<arg>

Less commonly used options:
        credentials=<filename>,guest,perm,noperm,setuids,nosetuids,rw,ro,
        sep=<char>,iocharset=<codepage>,suid,nosuid,exec,noexec,serverino,
        mapchars,nomapchars,nolock,servernetbiosname=<SRV_RFC1001NAME>
        directio,nounix,cifsacl,sec=<authentication mechanism>,sign

Options not needed for servers supporting CIFS Unix extensions
        (e.g. unneeded for mounts to most Samba versions):
        uid=<uid>,gid=<gid>,dir_mode=<mode>,file_mode=<mode>,sfu

Rarely used options:
        port=<tcpport>,rsize=<size>,wsize=<size>,unc=<unc_name>,ip=<ip_address>,
        dev,nodev,nouser_xattr,netbiosname=<OUR_RFC1001NAME>,hard,soft,intr,
        nointr,ignorecase,noposixpaths,noacl,prefixpath=<path>,nobrl

Options are described in more detail in the manual page
        man 8 mount.cifs

To display the version number of the mount helper:
        mount.cifs -V
0
LeviDaily
Asked:
LeviDaily
1 Solution
 
savoneCommented:
Here is an example:

mount.cifs //192.168.1.1/share /mnt/cifs -o username=windowsuser,password=windowspassword

If the share is avaiable to anyone and you don't need permissions you can skip the options:

mount.cifs //192.168.1.1/share /mnt/cifs

Of course remember you have to create the mount point first:
mkdir /mnt/cifs
0
 
LeviDailyAuthor Commented:
Ok, when I run it, I get this error...

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
0
 
Darr247Commented:
The mount.cifs program is called by mount if you use the '-t cifs' switch with it.

You say you installed the cifs package... which cifs package[s]?
It's usually installed with samba, since that's the mount type samba uses for shares by default.

try it like this
$ sudo mount -t cifs //192.168.1.1/share /mnt/cifs --verbose -o rw,user=MyUserName,password=MyPassWord

Open in new window

That should give you extra messages (though it looks like you're getting lots of messages already :) at every step of the process.

Once you get it to mount like that, you can put a line in the /etc/fstab file (without the -t and -o switches) and it should mount automatically at every restart.
0
 
LeviDailyAuthor Commented:
Weird -  still not mounting.. I installed cifs -utils & verified that samba-commons is installed.. Weird??

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
vyatta@vyatta:/mnt$
0
 
arunkeerthanCommented:
Use as below


mount -t cifs //192.168.1.1/share -o username=myusername,password='mypassword' /your/mount/point
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now