Error after configuring SSL for specific website in IIS 7

I'm running IIS 7 on a fresh install of Windows Server 2008 R2.

I've setup numerous sites in IIS (all except one are non-SSL/HTTPS). I configured one of the sites with the appropriate certificate and SSL, including a unique IP address only for that site, and selected it in the binding for HTTPS for that site.

However, when I try to hit the site via HTTPS, I get the following error:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

No problems hitting via HTTP, only HTTPS.

Has anyone experienced this and been able to resolve?

Thanks,
Dave
Dave_OAsked:
Who is Participating?
 
Dave_OAuthor Commented:
Even though I had added another IP address to the server for binding to the site with the SSL certificate, I ultimately had to turn off all the sites in IIS, give those sites (non-SSL) the new IP address and give the SSL site the original IP address of the server (not the new one I added).

Apparently there is some sort of binding with that first/original IP. There was probably a way to fix that but i went with above fix.

Once I started all the sites again, the SSL site worked with no problem as did the others.
0
 
Seaton007Commented:
There are a few different things that can cause this.

Are you browsing the site locally on the server, and if so what are you typing as the URL?
What browser are you using?  Chrome has had lots of problems with this.
Check your browser's proxy settings.  If the proxy settings aren't configured correctly, it can cause this issue as well.
0
 
Dave_OAuthor Commented:
No one else provided a solution I ultimately got it working myself and wanted to post what I did to make it work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.