Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2007
  • Last Modified:

Putty - copy from outlook a quoted command and paste into putty which changes them to periods

Putty - copy from outlook a quoted command and paste into putty which changes them to periods .

Yet same copy and paste to wordpad/notepad is no problem ( as is no problem to this posted question ) .

I copy this -

dumpulog “first=20120810,last=20120810,select=(10:13:20)” > userlog_20120810

And paste it into putty where it becomes this -

dumpulog .first=20120810,last=20120810,select=(10:13:20). > userlog_20120810

The quotes are changed into periods .

Yes I could just type it ...but copy paste is faster for me with one finger typing skills .
0
tennisdad
Asked:
tennisdad
  • 8
  • 3
  • 3
1 Solution
 
omarfaridCommented:
do you face the same problem when you copy from notepad or other windows apps and paste to putty? It could be a character set problem on putty.
0
 
tennisdadAuthor Commented:
I thought I tested that ....but .

This time I went back to word and notepad and just typed quotes around a word and copy/pasted from word and had the same quote to period translation happen ....but then went back to notepad and did the same and no sweat , as long as the data originated from notepad .

I know notepad is known to behave more as it doesn't DO things to help .

Went to wordpad and no sweat there ....but from outlook with it using word I have the issue .

I went to word directly and the same thing , quotes become periods .

I can take this same line ( from outlook using word or word directly ) and open vi and paste it to there and the quotes become periods .

I then edit it in vi ok and can copy paste out of vi or from the file created no sweat .

Bill Gates is after me I guess .
0
 
djcanterCommented:
Curly Quotes cause many issues when copy / pasting.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
omarfaridCommented:
did you try to check on the character set / language of putty?
0
 
djcanterCommented:
Turn off "smart quotes" in your Microsoft programs. That option
translates ' into either ’ or ‘ or one of the non-defined
chars between 128 and 160, depending on the codepage being used, the
nearby chars, and the phase of the moon. PuTTY tries to paste that
non-ASCII sequence as-is, and fails.
0
 
tennisdadAuthor Commented:
Yup.

In Putty configuration , Under Options controlling character set translation iso-8859-11998(Latin-1, West Europe) is selected and appaars to be the only one useful for American English .

Under that in quotes their is a note - ( Codepages supported by Windows but not listed here ., such as CP866 on many systems , can be entered manually ) .

If that is trying to tell me a different char set is available to handle this Windows Word to Putty quotes to periods I am not sure , nor do I have CP866 .
0
 
omarfaridCommented:
I tried the same and I could copy from notepad to putty and it is working!!!
0
 
djcanterCommented:
1.In the main Outlook window, on the Tools menu, click Options.
2.In the Options dialog box, click the Mail Format tab, and then click Editor Options.
3.In the Editor Options dialog box, click Proofing, and then click AutoCorrect Options.
4.In the AutoCorrect dialog box, do the following:
 Click the AutoFormat As You Type tab, and under Replace as you type, select or clear the "Straight quotes" with “smart quotes” check box.
Click the AutoFormat tab, and under Replace, select or clear the "Straight quotes" with “smart quotes” check box.
0
 
tennisdadAuthor Commented:
I had looked before to turn off any auto-formatting that word does and notepad/  wordpad apparently doesn't inflict on us .

I just re-read djcantors comments though -

Turn off "smart quotes" in your Microsoft programs. That option
translates ' into either ’ or ‘ or one of the non-defined
chars between 128 and 160, depending on the codepage being used, the
nearby chars, and the phase of the moon. PuTTY tries to paste that
non-ASCII sequence as-is, and fails.

This time when I went into word2007's word options/proofing/auto correct options/BOTH auto correct AND autocorrect as you type then UNCHECK  in BOTH replace straight quotes with smart quote ....DA DAAA !

Apparently Putty didn't understand what came into it and didn't said , "Hey , I on't know what that is and I'll put a period there you dummy until you give me something I do understand ".

Probably would have been nicer of Putty to give some error or log something that showed this is what you sent and this is what I did with it ...but it IS free ...sooo a period will have to do as a error flag .

Now I CAN copy from WORD2007  quotes to Putty .... and finally Putty gives just good 'ol quotes. .....but I go back to Outlook and same 'ol same 'ol quotes become periods ....getting close to full fix now .
0
 
tennisdadAuthor Commented:
Just went into Outlook2007 and darn if it doesn't have the same translation stuff.

So , went tools/options/spelling/spelling and autocorrection/proofing/autpcorrection options/

And there they are again (!) ....auto  correct AND correct as you type ....and now I replace as you type straight quotes with smart ( DUMB! ) quotes ....unchecked BOTH and still from Outlook2007 copy quotes and paste to Putty and they change to periods .....

Almost there ...so close .
0
 
tennisdadAuthor Commented:
I apparently have too many windows open and see djcantors -

1.In the main Outlook window, on the Tools menu, click Options.
2.In the Options dialog box, click the Mail Format tab, and then click Editor Options.
3.In the Editor Options dialog box, click Proofing, and then click AutoCorrect Options.
4.In the AutoCorrect dialog box, do the following:
 Click the AutoFormat As You Type tab, and under Replace as you type, select or clear the "Straight quotes" with “smart quotes” check box.
Click the AutoFormat tab, and under Replace, select or clear the "Straight quotes" with “smart quotes” check box.

Definitely had to do that ( as I posted ) ...but still same issue from Outlook (NOT Word any longer ) .

I closed all my mail and outlook sessions and the changes stuck ok ( unchecked aok ) but I still have the quotes to periods from Outlook .

There must be something I missed in Outlook.
0
 
tennisdadAuthor Commented:
I still have the problem into Putty ...but another term emulator called Ponderosa ( free ) does just fine ...for this situation anyway ( but I stopped using as it did some odd things when copy paste big files into VI ) .... so what have I missed concerning outlook2007 when copy quote from it and paste to Putty which becomes period .
0
 
tennisdadAuthor Commented:
It occurred to me that instead of copying from the mail I was sent today that had the original quotes I woud create my own email to test quotes to periods ....and so I opened it and copied from Outlook then I pasted to Putty aok (!) , no translation of quotes to periods ...UNTIL I go back to the original email and try to copy and paste from that ( from before I changed the autocorrect stuff ) .
0
 
tennisdadAuthor Commented:
Ok , so by changing the formatting as detailed above by djcantor and myself I can paste from Word or Outlook to Putty with no translation of quotes to periods ....UNLESS I go to the originally sent email which  RETAINS the bad boy smart quotes ( ! DARN ! ) .

I created a new email with outlook and copied the quoted line from the email sent before I changed the options on straight vs smart quotes AND typed into this same new email quotes around some text .

I sent it to myself and opened it .

I then saved the email as text and looked at it with a hex editor .

I found that my new text was aok when pasted to Putty and the previously created text still got translated from quotes to periods .

The smart quotes ( one is "forward" and the other is "backwards" ) showed up as hex 93 for the back quote and hex 94 for the forward quote .

The quotes I produced under no smart quotes are vertical looking and they are hex 22 .

dumpulog “first=20120810,last=20120810,select=(10:13:20)” > # bad smart quotes

"test" # these quotes work to Putty , no translation to periods

I was thinking that now that I changed the smart quotes option Bill Gates would nicely translate his smart quotes to straight quotes on previously received email but my test text shows the email made under smart quotes will retain  the smart quotes .

Thx all !
15aug12-smart-quotes-vs-straight.JPG
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 8
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now