• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1012
  • Last Modified:

Best Way to Deploy Application

Hi Experts!

    I need an quick, efficient and easy way to deploy an executable that resides on a VM on my network.  This VM also houses the backend database for this application (SQL Server 2008 R2) so they would somehow need to tie into the database as well.  About 6 to 10 people would be using this application.

    Any help with this is GREATLY APPRECIATED!  

P.S.  TS is not available on the 2008 Server box for some reason under "Server Manager." > Roles > Add Roles.
0
itsmevic
Asked:
itsmevic
3 Solutions
 
XaelianCommented:
Do you have a msi file of this executable? Or can you create a ZAP file from it? Then you can publish the application with a GPO.

Over here you can find the info to deploy an .msi file with a gpo:
http://support.microsoft.com/kb/816102
0
 
DustinKikuchiCommented:
In Server 2008 R2 Terminal Services was renamed to Remote Desktop Services.  If that's an option for you, start there.
0
 
itsmevicAuthor Commented:
The Remote Desktop Services is great.  I guess I need to put a copy of the .exe out there in each profiles Desktop?  I actually did that with one of my co-workers and he RDP'd out to that box, clicked on the .exe and is getting an error.  It's gotta be that it's not seeing the DB or he doesn't have the appropriate permissions to see the backend.  I've went in to the db and into the properties of the database > Permissions and have given "Guest" profile access to execute.  Still a no go though, he's getting the same dialog prompt.
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
DustinKikuchiCommented:
Once you've got the role setup you can do the following:
In Server Manager go to: Remote Desktop Services -> RemoteApp Manager

Right-click on the RemoteApp Programs table and "Add RemoteApp Programs"

Click "Next" and then either find the program in the list of programs, or if it is not there "Browse..." for it.

Click "Next" and "Finished"

After that has been done, highlight the app in the list and "Create .rdp file".  This will give you a RDP package that can be sent to your employees to use to launch the app.

**Note that you'll want to check your settings in the remoteapp area as you can change deployment options such as where RDP packages point to, etc.


Edit to add:  If he's able to remote desktop to the server and can't launch the application from there something else is probably wrong.  It could be permissions or something else entirely.  Hard to say without seeing the dialogue itself.
0
 
itsmevicAuthor Commented:
I've actually tried to create the .MSI and run the "Create .rdp" file both return the following error attached.  it's connecting to the VM like it should, prompts them to logon, which they do, then it even unwraps the .exe to the desktop.  They will get the error attached when trying to execute the application.  My application comes with a logon prompt, which you must enter credentials to get into it, but surely it wouldn't be asking for those credentials.  I've been having my two people that have been testing this on their boxes enter in their network login credentials, should they be entering in the applicaitons credentials instead?  Besides the executable should I also be adding something else with the database.  If I were a betting person I'd say they aren't seeing the database for some reason due to permissions issues with the database not the frontend app.


"dbreporting" is the name of the database""
Capture.JPG
0
 
DustinKikuchiCommented:
It looks as if RDP is doing what it should be doing.  I would guess that the app is at least finding the database as you're not getting an error stating that dbreporting cannot be found, but permissions do seem to be an issue.  Upon initial connection via RDP your users are likely being prompted for their credentials to log in to the server itself, however if they have saved those credentials it's entirely possible that they are being send directly to your application's login prompt.

If at all possible I would suggest trying to access the application via RDP yourself so that you can see exactly what is happening to get a better handle on the situation.  At this stage, unfortunately, remote diagnosis is going to be difficult.
0
 
itsmevicAuthor Commented:
My latest efforts:

1.)  Shared out the program folder on server that contains all of the applications files, .exe etc.
2.)  Installed .NET Frameworks 4.0 and Crystal Reports on client machine (Program needs these to run correctly.)
3.)  Created a shortcut to the .exe from the client machine to the server.
4.)  Should be able to login with application credentials at logon prompt of application (Not Server)

Getting this error now when doing the above:  See attached.
Capture.JPG
0
 
JustMy2CentsCommented:
RemoteExec should come handy here,  as this agentless, encrypted 3rd-party software:

- can be used to silently perform remote executions/installations in background, or can launch interactive executions displaying information to the user and requiring his interaction

- allows using impersonation accounts in order to perform remote executions throughout heterogeneous networks requiring different administrator accounts

- can execute complex, multiple step actions.
 In your case, you could for example configure the following: System wake up > Deployment of .NET Frameworks 4.0 and Crystal Reports > Deployment of your executable  >  System power off

Detailed info and free, fully-functional trial:
http://www.isdecisions.com/products/remoteexec/
0
 
itsmevicAuthor Commented:
Thanks for all the great input.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now