• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 741
  • Last Modified:

Putty - copy from outlook a quoted command and paste into putty which changes them to periods

Putty - copy from outlook a quoted command and paste into putty which changes them to periods -

Yet same copy and paste to wordpad/notepad is no problem ( as is no problem to this posted question ) .

I copy this -

dumpulog “first=20120810,last=20120810,select=(10:13:20)” > userlog_20120810

And paste it into putty where it becomes this -

dumpulog .first=20120810,last=20120810,select=(10:13:20). > userlog_20120810

The quotes are changed into periods .

Yes I could just type it ...but copy paste is faster for me with one finger typing skills .

I went back to word and notepad and just typed quotes around a word and copy/pasted from word and had the same quote to period translation happen ....but then went back to notepad and did the same and no sweat , as long as the data originated from notepad .

I know notepad is known to behave more as it doesn't DO things to help .

Went to wordpad and no sweat there ....but from outlook with it using word I have the issue .

I went to word directly and the same thing , quotes become periods .

I can take this same line ( from outlook using word or word directly ) and open vi and paste it to there and the quotes become periods .

I then edit it in vi ok and can copy paste out of vi or from the file created no sweat .

Bill Gates is after me I guess .
0
tennisdad
Asked:
tennisdad
  • 2
1 Solution
 
tennisdadAuthor Commented:
Solution here -

http://www.experts-exchange.com/Microsoft/Applications/Q_27829874.html#a38297455

Curly Quotes cause many issues when copy / pasting and are not the same as staight quotes visually or hex wise .

Turn off "smart quotes" in your Microsoft programs. That option
translates ' into either ’ or ‘ or one of the non-defined
chars between 128 and 160, depending on the codepage being used, the
nearby chars, and the phase of the moon. PuTTY tries to paste that
non-ASCII sequence as-is, and fails.

1.In the main Outlook window, on the Tools menu, click Options.
2.In the Options dialog box, click the Mail Format tab, and then click Editor Options.
3.In the Editor Options dialog box, click Proofing, and then click AutoCorrect Options.
4.In the AutoCorrect dialog box, do the following:
 Click the AutoFormat As You Type tab, and under Replace as you type, select or clear the "Straight quotes" with “smart quotes” check box.
Click the AutoFormat tab, and under Replace, select or clear the "Straight quotes" with “smart quotes” check box.

Note that docs produced under smart options will retain their "smartness" and continue to cause trouble even after the system is set to not use smart quotes .
0
 
tennisdadAuthor Commented:
Here is hex view of smart vs straight quotes .

Putty does not understand smart quotes that decode diffderently then straight quotes .
15aug12-smart-quotes-vs-straight.JPG
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now