• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 712
  • Last Modified:

Visual Studio 2012 on Windows 8

I am getting an error while trying to install VS2012 on Windows 8 release preview build 8400.

VS2012 install says that .Net version is not equal to or above 4.5.50709. I download the new versions of .Net and it says that they cannot install because .Net is already bundled into Windows 8.

Any help?


I have tried "Turn Windows Features ON/OFF" to uninstall and reinstall and nothing is working.
0
johnkubik
Asked:
johnkubik
1 Solution
 
Éric MoreauSenior .Net ConsultantCommented:
this version has problem. install the RTM version of Windows 8 made publicly available today.
0
 
Jacques Bourgeois (James Burger)Commented:
Both Windows 8 and VS2012 are in their development releases, so situations such as yours are to be expected.

The Release Preview of Windows 8 is quite old, and current releases of Visual Studio do not work with it. When you are working with pre-release versions, you need to make sure that you match the versions of the software you use. Visual Studio and the framework are automatically matched, but the OS and VS are not.
0
 
JGRobinsonCommented:
You need to remove .NET Framework 4.5 as well as the Visual Studio - if you have a problem doing this then you can run the .NET repair program which you can download from microsoft at http://www.microsoft.com/en-us/download/details.aspx?id=30135 which will definately remove it allowing you to put the latest RTM VS2012 version on.

Cheers
Graham
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now