Let users choose to use cached exchange mode

We had the "Use Cached Exchange Mode for new  and existing Outlook profiles" in a GPO set to disabled.  We have since decided to allow users to decide whether to use cached exchange mode (for reasons I will not get into) and set this setting back to Not Configured several weeks ago.  The Cached Exchange mode box in account settings is still grayed out in Outlook.  To my knowledge this is not set in any other GPO, but I wouldn't swear to it.  Any ideas on to let them choose?
LVL 5
rkeith2412Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

XaelianCommented:
Hi this is a problem you can resolve with recreating the outlook profile or the best solution do this on the affected pc's

1. Start a admin cmd (command prompt) window
2. Type regedit in the admin cmd window to launch Registry Editor
3. Go to HKEY_USER\User SID\Software\Microsoft\Office\12.0\Outlook\OST
4. Right click on the NoOST entry on the right and click Modify
5. Give it a value of 0
6. Restart Outlook 2007 and the Use Cached Exchange Mode option should no longer be grayed out anymore.

This is for office 2007, for office 2010 you need to change the 12.0 with 14.0

You could also create a logonscript that changes this for you on the affected pc's.
0
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Outlook 2010 Cached Mode Greyed Out
http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_26816692.html

have you looked on this key instead to see if a value is present ?
HKEY_CURRENT_USER\Software\Policies\\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\Outlook\dde8d87e8e2f31469579e0aceaef7bc1

- Rancy
0
rkeith2412Author Commented:
Xaelian,

The path is actually HKEY_USER\User SID\Software\Policies\Microsoft\Office\12.0\Outlook\OST but now my problem is how to deploy this.  The user only has read access if they go to HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\OST so I can't give them a .reg file to run.  I don't really want to remotely fix 500 machines, especially since I will have to look up everyone's SID.  Any ideas?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

XaelianCommented:
Hi,

Can you check following GP settings?

Domain Policy, User Settings, Admin Templates, MS Office/Email

Disable Cached Exchange Mode on new profiles
Check to disable Cached Exchange Mode on new profiles

Someone else had the same problem a time ago. Here is the link of this EE topic.
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23791615.html
0
rkeith2412Author Commented:
The creation of OST files was blocked by GP.  Once I disabled this policy Cached Exchange Mode started being allowed again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rkeith2412Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for rkeith2412's comment #a38302279
Assisted answer: 250 points for Xaelian's comment #a38300658

for the following reason:

Thanks for pointing me in the right direction.
0
XaelianCommented:
In my post the author accepted as assisted solution I've provided the whole solution he gives us.
0
rkeith2412Author Commented:
I didn't find the GPO items you mentioned, but it got me to a place where I found the "Do not allow an OST file to be created".  I still can't find the items you mentioned in your post.  That is why I awarded half the points to you.
0
XaelianCommented:
OK I understand. I thought that you had the Office GPO templates in your group policy object management window.

Because you didn't had it, those gpo settings weren't visible for you.

My bad, moderators can close my objection. Had to ask if office GPO templates were imported. Didn't thought about the fact, that I had installed them a time ago on my machine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.