Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco VPN tunnel not receiving

Posted on 2012-08-15
15
Medium Priority
?
1,233 Views
Last Modified: 2012-08-16
I created a VPN tunnel between 2 asa 5505 and the tunnel is up but it looks like communication is only going one way.

I checked the natting and the access-list and it should go both ways. if I checked the VPN tunnel status. it shows up but on asa 1 only TX traffic; RX traffic is 0 and on asa 2 it is the opposite. can someone check the configuration to see what I am missing here.

ASA 01

ASA Version 8.2(5) 
!
hostname PAJS

names
name 10.200.0.0 inside
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.200.248.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.x 255.255.255.0 
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network obj_any
 network-object 0.0.0.0 0.0.0.0
access-list outside_1_cryptomap extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
access-list inside_nat0_outbound extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.255.0.0 inside 255.255.0.0 
access-list InetInbound extended permit icmp any any 
access-list CorpOutbound extended permit ip any any 
access-list NoNat extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
pager lines 24

mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group CorpOutbound in interface inside
access-group InetInbound in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.200.248.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer y.y.y.y 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 86400
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure

crypto isakmp identity hostname 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.200.248.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 68.238.64.12 68.238.96.12
!
dhcpd address 10.200.248.5-10.200.248.36 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group y.y.y.y type ipsec-l2l
tunnel-group y.y.y.y ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
call-home reporting anonymous
: end

Open in new window


ASA 2


!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address y.y.y.y 255.255.255.240 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.0.10.2 255.255.255.0 
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 no ip address
 management-only
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 10.0.100.10
 name-server 10.0.100.12
 domain-name 
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list InetInbound extended deny ip 10.0.0.0 255.0.0.0 any 
access-list InetInbound extended deny ip 172.16.0.0 255.240.0.0 any 
access-list InetInbound extended deny ip 192.168.0.0 255.255.0.0 any 
access-list InetInbound extended permit icmp any any 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.0.200.0 255.255.255.0 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.200.248.0 255.255.252.0 
access-list CorpOutbound extended permit ip any host 10.0.10.2 
access-list CorpOutbound extended deny ip any 10.0.0.0 255.0.0.0 
access-list CorpOutbound extended deny ip any 172.16.0.0 255.240.0.0 
access-list CorpOutbound extended deny ip any 192.168.0.0 255.255.0.0 
access-list CorpOutbound extended deny icmp any host 68.85.191.49 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 any 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.0.200.0 255.255.255.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.200.248.0 255.255.252.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.200.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.1.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.200.0.0 255.255.0.0 
access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.0.0 10.200.0.0 255.255.0.0 
access-list Sandhill-VPN extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
pager lines 24
logging enable
logging buffer-size 128000
logging monitor debugging
logging buffered debugging
logging trap notifications
logging asdm debugging
mtu outside 1500
mtu inside 1500
mtu management 1500
ip local pool RemoteVPN 10.0.200.1-10.0.200.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NoNAT
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) y.y.y.y 10.0.30.10 netmask 255.255.255.255 
static (inside,outside) y.y.y.z 10.0.100.13 netmask 255.255.255.255 
access-group InetInbound in interface outside
access-group CorpOutbound in interface inside
route outside 0.0.0.0 0.0.0.0 y.y.y.y 1
route inside 10.0.0.0 255.0.0.0 10.0.10.1 1
route outside 10.1.0.0 255.255.0.0 y.y.y.y 1
route outside 10.200.248.0 255.255.252.0 y.y.y.y 1
timeout xlate 0:30:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AD protocol radius
aaa-server AD (inside) host 10.0.100.10
 key *****
 radius-common-pw *****
aaa-server AD (inside) host 10.0.100.12
 key *****
 radius-common-pw *****
aaa authentication http console AD LOCAL
aaa authentication telnet console AD LOCAL
aaa authentication ssh console AD LOCAL
aaa authentication enable console AD LOCAL
aaa accounting enable console AD
aaa accounting ssh console AD
aaa accounting telnet console AD
aaa authorization exec authentication-server
http server enable
http 10.0.0.0 255.0.0.0 inside
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps syslog
snmp-server enable traps ipsec start stop
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 86400
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map Outside_dyn_map 20 set pfs 
crypto dynamic-map Outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map Outside_dyn_map 20 set security-association lifetime seconds 28800
crypto dynamic-map Outside_dyn_map 20 set security-association lifetime kilobytes 4608000
crypto map Outside_map0 1 match address outside_1_cryptomap
crypto map Outside_map0 1 set peer x.x.x.x
crypto map Outside_map0 1 set transform-set ESP-3DES-SHA
crypto map Outside_map0 1 set security-association lifetime seconds 86400
crypto map Outside_map0 10 match address Sandhill-VPN
crypto map Outside_map0 10 set peer u.u.u.u
crypto map Outside_map0 10 set transform-set ESP-3DES-SHA
crypto map Outside_map0 10 set security-association lifetime seconds 86400
crypto map Outside_map0 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map0 interface outside

  quit
crypto isakmp identity hostname 
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh timeout 5
console timeout 0
management-access inside
!


!
phone-proxy ASA-phone-proxy
 media-termination mediaterm1
 tftp-server address 10.0.30.10 interface inside
 tls-proxy ASA-tls-proxy
 ctl-file ctl_phoneproxy_file
 no disable service-settings
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server 10.0.10.1 source inside
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.5.0217-k9.pkg 1
 svc image disk0:/anyconnect-macosx-i386-2.5.0217-k9.pkg 2
 svc image disk0:/anyconnect-linux-2.5.0217-k9.pkg 3
 svc enable
group-policy SSLPolicy internal
group-policy SSLPolicy attributes
 dns-server value 10.0.100.10 10.0.100.12
 vpn-idle-timeout 86400
 vpn-session-timeout 86400
 vpn-tunnel-protocol svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RemoteVPN_splitTunnelAcl
 default-domain value 
 address-pools value RemoteVPN
 webvpn
  svc keep-installer installed
  svc keepalive 15
  svc ask none default svc
  url-entry enable
group-policy RemoteVPN internal
group-policy RemoteVPN attributes
 dns-server value 10.0.100.10 10.0.100.12
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RemoteVPN_splitTunnelAcl
 default-domain value 
username peery password JzCzcdjFEBGzOwyW encrypted privilege 15
tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool RemoteVPN
 authentication-server-group AD
 default-group-policy SSLPolicy
tunnel-group RemoteVPN type remote-access
tunnel-group RemoteVPN general-attributes
 address-pool RemoteVPN
 authentication-server-group AD
 default-group-policy RemoteVPN
tunnel-group RemoteVPN ipsec-attributes
 pre-shared-key *****
tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
 pre-shared-key *****
tunnel-group u.u.u.u type ipsec-l2l
tunnel-group u.u.u.u ipsec-attributes
 pre-shared-key *****
!
class-map sec_sip
 match port tcp eq 5061
class-map Voice_SIG
 match dscp cs3 
class-map Voice_RTP
 match dscp ef 
class-map sec_sccp
 match port tcp eq 2443
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect xdmcp 
  inspect netbios 
  inspect pptp 
  inspect ip-options 
policy-map voice_policy
 class sec_sccp
  inspect skinny phone-proxy ASA-phone-proxy 
 class sec_sip
  inspect sip phone-proxy ASA-phone-proxy 
!
service-policy global_policy global
service-policy voice_policy interface outside
prompt hostname context 
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:d631db1019d0a43b682f55db57ba38d0
: end

Open in new window

0
Comment
Question by:odewulf
  • 9
  • 6
15 Comments
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38299393
Check routing on both sides.

What is your default gateways on both ends?
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38299407
Wait a minute, you are missing inbound access lists

ASA 1:


access-list InetInbound extended permit ip 10.0.10.0 255.255.255.0  inside 255.255.0.0

on ASA 2

no access-list InetInbound extended deny ip 10.0.0.0 255.0.0.0 any
access-list InetInbound extended permit ip 10.200.248.0 255.255.255.0 10.0.0.0 255.0.0.0
0
 

Author Comment

by:odewulf
ID: 38300571
let me check but I have a 3rd ASA with a vpn tunnel that works just fine and I don't have those as I have added those access list

access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.0.0 10.200.0.0 255.255.0.0 (for asa 1)
access-list Sandhill-VPN extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 (for asa 2)
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 18

Expert Comment

by:fgasimzade
ID: 38300637
There are 2 different types of access lists: crypto access lists are used in cryptomaps to identify interesting traffic. The second type is a normal access list, which should be configured on outside interface to allow traffic from outside to inside
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38300638
Access lists i suggested are outside access lists, access lists you provided are crypto access lists. its 2 different things
0
 

Author Comment

by:odewulf
ID: 38300683
the crypto access list should be all I need though, doesn't it as all I care is the VPN tunnel traffic going from 10.0.0.0 to 10.200.0.0
it seems to be going ok from 10.200.0.0 but not the other way.
Plus this configuration is working fine for my 3rd asa with the same access list.

thank for your help
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38300798
Your outside access list on second asa block traffic from asa 1

You need those access list changes I suggested.
0
 

Author Comment

by:odewulf
ID: 38301014
ok I changed that but still no traffic going from Asa 2 to asa 1 :-/
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38301115
can you post your configs again? what are default gateways on both networks? you can not ping accross tunnel at all or its a one way communication?
0
 

Author Comment

by:odewulf
ID: 38301352
I can't ping from any side but if I look at the VPN monitoring it looks like packets are sent from asa 1 to asa 2 but the the receiving showed 0 packet last night (not it is about 700 compared to hundred thousands on the other direction).

I would rather not post the gateway on here as they are IP addresses that people could use sorry.

Result of the command: "sh run"

: Saved
:
ASA Version 8.2(5) 
!
hostname PAJS
enable password vmTqXBRV1PlMK7e4 encrypted

names
name 10.200.0.0 inside
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.200.248.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address y.y.y.y 255.255.255.0 
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network obj_any
 network-object 0.0.0.0 0.0.0.0
access-list outside_1_cryptomap extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
access-list inside_nat0_outbound extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.255.0.0 inside 255.255.0.0 
access-list InetInbound extended permit icmp any any 
access-list InetInbound extended permit ip 10.0.0.0 255.255.0.0 inside 255.255.0.0 
access-list CorpOutbound extended permit ip any any 
access-list NoNat extended permit ip inside 255.255.0.0 10.0.0.0 255.255.0.0 
pager lines 24
logging enable
logging list vpn level debugging class vpdn
logging list vpn level debugging class vpn
logging list vpn level debugging class vpnc
logging asdm alerts
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group CorpOutbound in interface inside
access-group InetInbound in interface outside
route outside 0.0.0.0 0.0.0.0 y.y.y.m 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.200.248.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer z.z.z.z
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 86400
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity hostname 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.200.248.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 68.238.64.12 68.238.96.12
!
dhcpd address 10.200.248.5-10.200.248.36 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group z.z.z.z type ipsec-l2l
tunnel-group z.z.z.z ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
call-home reporting anonymous
Cryptochecksum:ddb70c2fd98fda66ff6b011422072f9c
: end

Open in new window


asa 2

Result of the command: "sh run"

: Saved
:
ASA Version 8.2(2) 
!

names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address z.z.z.z 255.255.255.240 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.0.10.2 255.255.255.0 
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 no ip address
 management-only
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 10.0.100.10
 name-server 10.0.100.12
 domain-name 
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list InetInbound extended deny ip 172.16.0.0 255.240.0.0 any 
access-list InetInbound extended deny ip 192.168.0.0 255.255.0.0 any 
access-list InetInbound extended permit icmp any any 
access-list InetInbound extended permit ip 10.200.0.0 255.255.0.0 10.0.0.0 255.0.0.0 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.0.200.0 255.255.255.0 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 10.200.248.0 255.255.252.0 
access-list CorpOutbound extended permit ip any host 10.0.10.2 
access-list CorpOutbound extended deny ip any 10.0.0.0 255.0.0.0 inactive 
access-list CorpOutbound extended deny ip any 172.16.0.0 255.240.0.0 
access-list CorpOutbound extended deny ip any 192.168.0.0 255.255.0.0 
access-list CorpOutbound extended deny icmp any host 68.85.191.49 
access-list CorpOutbound extended permit ip 10.0.0.0 255.255.0.0 any 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.0.200.0 255.255.255.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.200.248.0 255.255.252.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
access-list NoNAT extended permit ip 10.0.0.0 255.255.0.0 10.200.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.1.0.0 255.255.0.0 
access-list RemoteVPN_splitTunnelAcl standard permit 10.200.0.0 255.255.0.0 
access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.0.0 10.200.0.0 255.255.0.0 
access-list Sandhill-VPN extended permit ip 10.0.0.0 255.255.0.0 10.1.0.0 255.255.0.0 
pager lines 24
logging enable
logging buffer-size 128000
logging monitor debugging
logging buffered debugging
logging trap notifications
logging asdm debugging
mtu outside 1500
mtu inside 1500
mtu management 1500
ip local pool RemoteVPN 10.0.200.1-10.0.200.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NoNAT
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) z.z.z.i 10.0.30.10 netmask 255.255.255.255 
static (inside,outside) z.z.z.p 10.0.100.13 netmask 255.255.255.255 
access-group InetInbound in interface outside
access-group CorpOutbound in interface inside
route outside 0.0.0.0 0.0.0.0 z.z.z.w 1
route inside 10.0.0.0 255.0.0.0 10.0.10.1 1
route outside 10.1.0.0 255.255.0.0 z.z.z.w 1
route outside 10.200.248.0 255.255.252.0 z.z.w 1
timeout xlate 0:30:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AD protocol radius
aaa-server AD (inside) host 10.0.100.10
 key *****
 radius-common-pw *****
aaa-server AD (inside) host 10.0.100.12
 key *****
 radius-common-pw *****
aaa authentication http console AD LOCAL
aaa authentication telnet console AD LOCAL
aaa authentication ssh console AD LOCAL
aaa authentication enable console AD LOCAL
aaa accounting enable console AD
aaa accounting ssh console AD
aaa accounting telnet console AD
aaa authorization exec authentication-server
http server enable
http 10.0.0.0 255.0.0.0 inside

snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps syslog
snmp-server enable traps ipsec start stop
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 86400
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map Outside_dyn_map 20 set pfs 
crypto dynamic-map Outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map Outside_dyn_map 20 set security-association lifetime seconds 28800
crypto dynamic-map Outside_dyn_map 20 set security-association lifetime kilobytes 4608000
crypto map Outside_map0 1 match address outside_1_cryptomap
crypto map Outside_map0 1 set peer y.y.y.y
crypto map Outside_map0 1 set transform-set ESP-3DES-SHA
crypto map Outside_map0 1 set security-association lifetime seconds 86400
crypto map Outside_map0 10 match address Sandhill-VPN
crypto map Outside_map0 10 set peer q.q.q.q
crypto map Outside_map0 10 set transform-set ESP-3DES-SHA
crypto map Outside_map0 10 set security-association lifetime seconds 86400
crypto map Outside_map0 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map0 interface outside

  
  
crypto isakmp identity hostname 
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh timeout 5
console timeout 0
management-access inside
!
tls-proxy ASA-tls-proxy
 server trust-point _internal_PP_ctl_phoneproxy_file
ctl-file ctl_phoneproxy_file
 record-entry cucm-tftp trustpoint phoneproxy_trustpoint address 68.65.76.40
 no shutdown
!
media-termination mediaterm1
 address 68.65.76.41

!
phone-proxy ASA-phone-proxy
 media-termination mediaterm1
 tftp-server address 10.0.30.10 interface inside
 tls-proxy ASA-tls-proxy
 ctl-file ctl_phoneproxy_file
 no disable service-settings
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server 10.0.10.1 source inside
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.5.0217-k9.pkg 1
 svc image disk0:/anyconnect-macosx-i386-2.5.0217-k9.pkg 2
 svc image disk0:/anyconnect-linux-2.5.0217-k9.pkg 3
 svc enable
group-policy SSLPolicy internal
group-policy SSLPolicy attributes
 dns-server value 10.0.100.10 10.0.100.12
 vpn-idle-timeout 86400
 vpn-session-timeout 86400
 vpn-tunnel-protocol svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RemoteVPN_splitTunnelAcl
 default-domain value 
 address-pools value RemoteVPN
 webvpn
  svc keep-installer installed
  svc keepalive 15
  svc ask none default svc
  url-entry enable
group-policy RemoteVPN internal
group-policy RemoteVPN attributes
 dns-server value 10.0.100.10 10.0.100.12
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RemoteVPN_splitTunnelAcl
 default-domain value 

tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool RemoteVPN
 authentication-server-group AD
 default-group-policy SSLPolicy
tunnel-group RemoteVPN type remote-access
tunnel-group RemoteVPN general-attributes
 address-pool RemoteVPN
 authentication-server-group AD
 default-group-policy RemoteVPN
tunnel-group RemoteVPN ipsec-attributes
 pre-shared-key *****
tunnel-group y.y.y.y type ipsec-l2l
tunnel-group y.y.y.y ipsec-attributes
 pre-shared-key *****
tunnel-group q.q.q.q type ipsec-l2l
tunnel-group q.q.q.qa ipsec-attributes
 pre-shared-key *****
!
class-map sec_sip
 match port tcp eq 5061
class-map Voice_SIG
 match dscp cs3 
class-map Voice_RTP
 match dscp ef 
class-map sec_sccp
 match port tcp eq 2443
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect xdmcp 
  inspect netbios 
  inspect pptp 
  inspect ip-options 
policy-map voice_policy
 class sec_sccp
  inspect skinny phone-proxy ASA-phone-proxy 
 class sec_sip
  inspect sip phone-proxy ASA-phone-proxy 
!
service-policy global_policy global
service-policy voice_policy interface outside
prompt hostname context 
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:2891aea3045f4ee318e007b9deeb89f6
: end

Open in new window

0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38301361
I need your default gateways on your inside networks, just to make sure your routing is properly configured.
0
 

Author Comment

by:odewulf
ID: 38301435
on asa 1 it goes to 10.200.248.1
on asa 2 it goes to 10.0.x.1 where x is the Vlan for server it is 100 for phone it is 30 and for workstation it is 20

thank you for your help
0
 
LVL 18

Accepted Solution

by:
fgasimzade earned 2000 total points
ID: 38301480
So on side 2 asa 2 is not your default gateway for inside, correct?

your asa 2 has 10.0.10.2 configured on inside
interface.  And you have a route 10.0.0.0 pointing to 10.0.10.1.. which device is it? can you describe your asa 2 topology?
0
 

Author Closing Comment

by:odewulf
ID: 38301943
OK i figured the issue...nothing to do with the ASA but I had to add a route to the switch to direct all 10.200.248.0 traffic to the correct gw.


thank you for directing me in the right direction.
0
 
LVL 18

Expert Comment

by:fgasimzade
ID: 38301969
Well done!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question