• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 624
  • Last Modified:

Relaying stopped working on Exchnage 2010

Hello,

I have set up a Connector in Exchange 2010 under Server configuration Hub Transport called Relay. This allows users specified on an ip address list to send email through exchange.

Reason being, a few users have 2 email addresses, the Exchnage address and a pop email address for another domain. Email is delivered fromt he pop address to the exhange inbox and I want the user to be able to send a new email from either address. No problem with the @exchange address, all working fine, but the @popaddress needs permission to relay through exchange.

All of a sudden one user can no longer relay. I've checked the machines ip is on the list but I just get Server error: '550 5.7.1 Unable to relay'.

I sent an email from another machine on the ip list and it realyed no problem.

If I send an email to an internal email it sends, it just won't relay to an external address. Telneted to the exchange server and sent an email from command line and got the same message.

Any ideas?
0
RossJaye
Asked:
RossJaye
  • 14
  • 9
1 Solution
 
MASTechnical Department HeadCommented:
Go to Account settings --> Open POP account settings -->More Settings-->Outgoing server
Tick 'My outgoing (SMTP) server requires authentication'
and select 'use same settings as my incoming mail server'

Try this first
0
 
RossJayeAuthor Commented:
Hi,

Thanks. The SMTP server is the local exchange server as the machine is on a domain, if i tick use authentication as you suggest all that happens is that Outlook will pass the pop account username and password tot he exchange server for authentication and this will obviously fail.

The thing I am seeing is if I telnet to myexchangeserver 25 and then helo
mail from: mypop@address.co.uk
250 2.1.0 mypop@address.co.uk... Sender ok
RCPT TO: mail@otherdomain.ext
unable to relay

So I am looking at my Relay connector on the Exchange server and the IP address of the sending PC IS on the list of machines allowed to relay through exchange so how come I'm getting unable to relay? Also other machine on the same network that appear on the same list ARE able to relay through exchange.

ie if I go to another PC which has a similar setup and telnet

mail from: mypop@address.co.uk
250 2.1.0 mypop@address.co.uk... Sender ok
RCPT TO: mail@otherdomain.ext
250 2.1.0 mail@otherdomain.ext... Recipient ok

and then send mail.
0
 
MASTechnical Department HeadCommented:
Add the first PC's IP (which has problem) to the receive connector 'Relay' as permitted IP address and try
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
RossJayeAuthor Commented:
Thanks but as I said above

"All of a sudden one user can no longer relay. I've checked the machines ip is on the list but I just get Server error: '550 5.7.1 Unable to relay'."

The IP of that machine IS already on the list. Doubled checked.
0
 
RossJayeAuthor Commented:
Interestingly it seems to be Windows 7 client PC's that cannot relay. I just tried another machine using the telnet command and then a 3rd (XP machine) the W7 machine said unable to relay even though it's IP is on the list however the XP machine sent the mail - it's ip is on the list but removing it it is then unable to relay - add it back and it can once more.

So this seems to be Windows 7?
0
 
RossJayeAuthor Commented:
Tried adding in the ipv6 address, same thing unable to relay
0
 
RossJayeAuthor Commented:
Can anyone verify what should be set on the relay connector dialogues? The network tab has the list of IPs that can relay. What should be set on the Authentication tab and the Permission Groups tab? In exchange management console.
0
 
RossJayeAuthor Commented:
I just tried an XP client. Telnet to myexchange server 25

helo

mail from: me@mydomain.co.uk
250 2.1.0 me@mydomain.co.uk... Sender ok
RCPT TO: mail@otherdomain.ext
unable to relay

Then added the ip of that machine to thr realy connector and repeated the above

mail from: me@mydomain.co.uk
250 2.1.0 me@mydomain.co.uk... Sender ok
RCPT TO: mail@otherdomain.ext
Recipient ok

data

blah blah
.
Mail queued
Mail arrived

So this IS a Windows 7 - exchange problem. Any more thoughts anyone. Firewalls turned off
0
 
RossJayeAuthor Commented:
Apparently no one has anything to say about this. Ah well.
0
 
MASTechnical Department HeadCommented:
Still you have problem relaying?

I thought it is fixed by adding that ip in the rcv connector
0
 
RossJayeAuthor Commented:
I'm still not able to relay from any W7 PCs. All XP machines are fine. I've added in the ipv6 address to the connector and disabled ipv6 on the w7 machines.
0
 
MASTechnical Department HeadCommented:
Do the same step you did in post#38300193  from a windows7 PC and check
0
 
RossJayeAuthor Commented:
OK ipv6 is not on. Here is ipconfig/all for that machine

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : rossjaye.rossjayevelleman.co.uk
   Description . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connecti
on
   Physical Address. . . . . . . . . : 18-03-73-19-ED-B6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 132.147.157.78(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Lease Obtained. . . . . . . . . . : 16 August 2012 09:28:43
   Lease Expires . . . . . . . . . . : 24 August 2012 09:31:45
   Default Gateway . . . . . . . . . : 132.147.155.150
   DHCP Server . . . . . . . . . . . : 132.147.155.143
   DNS Servers . . . . . . . . . . . : 132.147.155.143
                                       132.147.155.120
   NetBIOS over Tcpip. . . . . . . . : Enabled

The ip address 132.147.157.78 is on the list in the receiver. Now I runt he following telnet, both addresses are valid and waiting to receive mail.

220 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Microsoft ESMTP MAIL Service read
y at Sat, 18 Aug 2012 10:45:53 +0100
helo
250 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Hello [2002:8493:9d4e::8493:9d4e]
mail from: robertmallett@puresource.fr
250 2.1.0 Sender OK
rcpt to: robertmallett@puresource.co.uk
550 5.7.1 Unable to relay

That's the problem. If I repeat this command on a Windows XP machine whose IP is on the list I cans end mail, if I remove this IP fromt he list I am unable to relay as you would expect.

So....going over old ground why are the XP machines allowed to relay and the Windows 7 are not?
0
 
MASTechnical Department HeadCommented:
Add network range of 132.147.1.1-132.147.255.254 in your receive connector 'Relay'

Restart Exchange transport service and try once more please.
0
 
RossJayeAuthor Commented:
I followed your instructions

220 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Microsoft ESMTP MAIL Service read
y at Sat, 18 Aug 2012 11:18:45 +0100
helo
250 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Hello [2002:8493:9d4e::8493:9d4e]
mail from: robertmallett@puresource.fr
250 2.1.0 Sender OK
rcpt to: robertmallett@puresource.co.uk
550 5.7.1 Unable to relay
0
 
MASTechnical Department HeadCommented:
Did you enable this in ur POP account?
Just to confirm
Go to Account settings --> Open POP account settings -->More Settings-->Outgoing server
Tick 'My outgoing (SMTP) server requires authentication'
and select 'use same settings as my incoming mail server'
0
 
RossJayeAuthor Commented:
As the telnet session does not send then isn't it kind of irrelevant what the settings are in Outlook?

If I do as you suggest then all that will happen is that Outlook will hand over the incoming pop account details to the internal Exchange server which will not recognize them at all.

Also I don't do this on the XP machines (same version of Outlook - 2010), the machines are allowed to relay if they are on the ip list, no authentication boxes ticked in outlook and the telnet commands send mail.
0
 
MASTechnical Department HeadCommented:
make sure you these permissions in the new rcv connector.
if there is change please restart the transport service
permissions.docx
0
 
RossJayeAuthor Commented:
Hi,

Thanks.

 All 3 boxes are ticked and I did just restart the transport just incase

220 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Microsoft ESMTP MAIL Service read
y at Sat, 18 Aug 2012 12:50:13 +0100
helo
250 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Hello [2002:8493:9d4e::8493:9d4e]
mail from: robertmallett@puresource.fr
250 2.1.0 Sender OK
rcpt to: robertmallett@puresource.co.uk
550 5.7.1 Unable to relay

and just so we know it's working OK here's the outpu from an XP machine

220 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Microsoft ESMTP MAIL Service read
y at Sat, 18 Aug 2012 12:52:49 +0100
helo
250 EXCHANGE03.rossjaye.rossjayevelleman.co.uk Hello [132.147.155.120]
mail from: robertmallett@puresource.fr
250 2.1.0 Sender OK
rcpt to: robertmallett@puresource.co.uk
250 2.1.5 Recipient OK
data
354 Start mail input; end with <CRLF>.<CRLF>
 hello mail
.
250 2.6.0 <3b0114c6-2665-401b-abb1-c550bd4bb6be@EXCHANGE03.rossjaye.rossjayevell
eman.co.uk> [InternalId=1947151] Queued mail for delivery

Puzzled? I am.
0
 
MASTechnical Department HeadCommented:
Seems like your windows7 PC is trying to connect by IPv6.
either you disable IPV6 in server or make sure you have these entries in the network tab of your rcv connector
rcv-networks.docx
0
 
RossJayeAuthor Commented:
That is exactly how it is set on the rcv connector already and ipv6 is disabled already.

See cap attached.
rcv-conn.jpg
0
 
RossJayeAuthor Commented:
I solved it by disabling something called Microsoft 6to4 Adapter which showed up in Device Manager on the W7 machine as a hidden device.
Can't find out much about this but it seems that even though ipv6 is disabled in the adapter settings on both the workstation and the exchange server, and despite the fact that when ipv6 was enabled I had entered the ipv6 address in the connector list on exchange it still would not relay.
Disabling this Tunnel Adapter has (I guess) returned the PC to more of a legacy setup.

Any info on what, why and how this Tunnel Adapter is would be appreciated.

To disable - Command Prompt and run as administrator, type the command netsh in 6to4 set state disable, press Enter. The component will be disabled and hidden.
0
 
MASTechnical Department HeadCommented:
I have commented about IPv6 just above ur comment. rest is ur part to make sure they are not using IPv6
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 14
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now