We help IT Professionals succeed at work.

pen drive

venkatspb
venkatspb asked
on
Medium Priority
694 Views
Last Modified: 2012-08-30
Dear All,

I am not able to format the pen drive shows "pen drive showing write protected"

need a solution.

regards,
venkat
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2015
Commented:
Was it working before or is it new? If it is new, check if there is a slider or something similar to write protect it. Also check whether there is software installed on it that could prevent formatting, like encryption etc., and make sure you aren't accessing any data on it while you try formatting.

If it is used and worked before, then you should accept that it is broken and properly dispose it.
Linux Admin
Commented:
Go to Run->regedit
MyComputer->HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->Control -> StorageDevicePolicies
Delete the StorageDevicePolicies in Your Registry.

Now You can format the Pendrive
According to the following thread you have to follow this procedure:

http://en.kioskea.net/forum/affich-32020-write-protected-pendrive-can-not-format

1. insert the pendrive
2. dont open or format it directly
3. right click on my computer and go to manage
4.in computer managment window click on disk managment option
5. right click on the removable disk (i,h....)
6. select format
Sridhar CherukuriService Engineer
Commented:
If it is accessible then check if it has write protect on and off switch (Some pen drives will have this switch)

Otherwise try this

Open Regedit
Expand HKEY_LOCAL_MACHINE
Expand System
Expand CurrentControlSet
Expand Control

Look for StorageDevicePolicies and set its value to 0

If you dont see it then Right Click on  Control - > New -> and on the right window click on new -> DWORD 32 Bit Value

in the right window change its name to StorageDevicePolicies and set the value to 0 and close the regedit and restart the computer and try to format the pen drive
CERTIFIED EXPERT
Most Valuable Expert 2015
Commented:
I forgot to ask earlier, what OS are you trying to format it from? What file-system is it currently using? If your OS doesn't support the file-system that the stick is currently using, you may first have to delete the partition, then create a new one.

Also, if you are trying to do this on a company PC which is locked down with policies you might not be allowed to use sticks or format them...
venkatspbSenior Software Engineer

Author

Commented:
not able to format even after removing the StorageDevicePolicies"  from my registry.
Sridhar CherukuriService Engineer

Commented:
is it accessible?
Sridhar CherukuriService Engineer
Commented:
Thoughts in my mind

1. If you are able to open the USB stick and view the contents in it then see if you have autorun.inf file. If you see that do a virus scan on it to remove the autorun.inf and then format it.

2. If the above is not the reason, then the cuase could be due to the flash chip failure in the USB stick. Nothing can be done.
Commented:
I have had drives go bad like this before.  If the above regedit's did not work and you have checked for a slider on the drive, you're most likely out of luck.  Always make sure you don't remove a drive before properly ejecting it in windows.  This has killed drives I've owned in the past.  If it is a new drive consider taking it back to the store you purchased it from.  What actually ended up fixing my drive that was giving the same error was using the HP drive tool to format it it.  Doing a low level format will wipe ALL the data on the drive so beware, but since you can't access it anyways, it's worth a shot.  

Here's a link for the tool i mentioned:
http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
test if it works on other USB ports - or on another PC
it can be bad..
venkatspbSenior Software Engineer

Author

Commented:
Thanks

Explore More ContentExplore courses, solutions, and other research materials related to this topic.