Cisco Remote Access VPN IPSec (ASA 5505)

Posted on 2012-08-16
Last Modified: 2012-08-23
I was hoping someone could take a look at my config file and lend a helping hand. I have an issue with the IPSec VPN tunneling on my Cisco box.

Outside clients trying to connect to my office's VPN have no problem building a tunnel but no one can access the internal network, i.e. internal NAS, internal computers through VNC, etc.

I can ping my network's firewall from its inside IP and I can access it through ssh but that is the extent of my communciation with my internal network. Any help would be greatly appreciated.

ASA Version 8.3(1)
hostname AxxxxxASA
domain-name axxxx.local
enable password xxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxx encrypted
interface Vlan1
 nameif inside
 security-level 100
 ip address
interface Vlan2
 nameif outside
 security-level 0
 ip address
interface Ethernet0/0
 switchport access vlan 2
boot system disk0:/asa831-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name argent.local
object network obj_any
object service Passive_FTP
 service tcp source range 5010 5030
object network OutsideIP
object network FTP_Server
object service FTP
 service tcp source eq ftp
object network vpnpool
object network inside_network
object-group network group-inside-vpnclient
 description all inside accessible networks
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list outside_access_in extended permit tcp any object FTP_Server eq ftp
access-list outside_access_in extended permit tcp any object FTP_Server range 5010 5030
access-list acl-vpnclient extended permit ip
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool ippool-vpnclient mask
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static FTP_Server OutsideIP service Passive_FTP Passive_FTP
nat (inside,outside) source static FTP_Server OutsideIP service FTP FTP
nat (inside,any) source static inside_network inside_network destination static vpnpool vpnpool
object network obj_any
 nat (inside,outside) dynamic interface
object network inside_network
 nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http inside
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set xform-3des-md5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dcmap-vpnclient 1 set pfs group1
crypto dynamic-map dcmap-vpnclient 1 set transform-set xform-3des-md5
crypto map cmap-vpncient 65535 ipsec-isakmp dynamic dcmap-vpnclient
crypto map cmap-vpncient interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal 3600
telnet timeout 5
ssh inside
ssh inside
ssh timeout 5
console timeout 0
management-access inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy group-policy-default internal
group-policy group-policy-default attributes
 banner value Welcome to Argent's VPN
 dns-server value
 vpn-tunnel-protocol IPSec
 password-storage disable
 re-xauth disable
 pfs disable
 ipsec-udp enable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value
 default-domain value argent.LOCAL
username jxxxxx password ***********/ encrypted
tunnel-group vpnclient type remote-access
tunnel-group vpnclient general-attributes
 address-pool ippool-vpnclient
 default-group-policy group-policy-default
tunnel-group vpnclient ipsec-attributes
 pre-shared-key *****
class-map ftp-class
class-map inspection_default
 match default-inspection-traffic
policy-map type inspect dns preset_dns_map
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
 class ftp-class
  inspect ftp
: end
Question by:JBober14
    LVL 18

    Accepted Solution

    You miss an access-list statement:

    access-list outside_access_in extended permit ip

    Author Comment

    I added the above line as well as  "split-tunnel-network-list value vpnclient"

    Still no good. I was contemplating just wiping the VPN config clean and restarting... anyone have any suggestions for a good tutorial for the ASA using IPSec tunneling and v 8.3?

    Author Comment

    I have set the proper vpn attributes to the clients so they can now use the internet while the tunnel is enabled. I can also access client computers through a VNC connection.

    My only problem is I cannot map network drives so I can access files through the VPN tunnel... again I would appreciate any help

    Author Comment

    The issue was the internal gateway. Most systems on the network were setup for a address not .5 once I changed the internal devices everything began to work as it should.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    Join & Write a Comment

    I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
    Hi All,  Recently I have installed and configured a Sonicwall NS220 in the network as a firewall and Internet access gateway. All was working fine until users started reporting that they cannot use the Cisco VPN client to connect to the customer'…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now