problem mounting usb drive in linux

Hi,

I have come across this problem so many times in Linux, its breaking my heart :(

i am trying to mount a usb drive and i am getting the attached errors, if anybody can help me i would be so happy.
photo.JPG
jonathanduane2010Asked:
Who is Participating?
 
Darr247Connect With a Mentor Commented:
To install ntfs-3g in Ubuntu, you would run
$ sudo apt-get ntfs-3g*

That should install 3 (or more, with dependencies and regex matches for ntfs-3g*) packages.
0
 
jonathanduane2010Author Commented:
sorry that image isnt great quality here it is
photo.JPG
0
 
Darr247Commented:
Do you have the ntfs-3g package[s] installed, so you can try mounting it as NTFS?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jonathanduane2010Author Commented:
i dont know, how do i do that??
0
 
nociSoftware EngineerCommented:
What actualy is the filesystem on usb drive.
If NTFS see above comment about the ntfs-3g package. [ It is a user mode filesystem driver ]
[this seems most probable]
The actual name and installation method depends on your distro.
NTFS is not a native filesystem for linux systems, it a reverse engineered driver and might require regular updates if a windows update for one of the windows versions is released.
[after release of windows updates people can try to find out if there might have been incompatible changes made by Microsoft.]

If the message is about the sudo mount, try a ',' (COMMA) instead of a '.' (DECIMAL-POINT)
between the uid= &gid= options.
0
 
jonathanduane2010Author Commented:
ok i have got it mounted ands its mounted as sde1 and it didnt give me any errors at all. but when i try and cd to dev/sde1 it says "no such file or directory"
0
 
nociConnect With a Mentor Software EngineerCommented:
You mount a device onto the mount point.
The device path is for raw access, the mount point if for file access.

So if /dev/sde1 is mounted onto mountpoint /mnt/sde1 you can use:
   cd /mnt/sde1
to access the device.

BTW was it NTFS of FAT?  [ just for future reference for readers of the question when having similar problems ].
0
 
Diogo UchoasConnect With a Mentor Network and Security AnalystCommented:
try installing ntfs-3g and then try again.
apt-get install ntfs-3g or yum install ntfs-3g.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.