• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3542
  • Last Modified:

SBS 2011 Connector - Dashboard shows computers offline

Hello all,

I have recently set up a new server running SBS 2011 and everything has gone wonderfully till this point. There are four computers at the moment that I have installed the connector on via http://"server name"/connector. One of these computers shows up just fine, I am able to schedule backups and all of it. The other three all show up as offline and all detail shows unavailable. I have searched and searched for a solution to no avail. The computers are running Windows 7 x64 Pro and have all updates etc.

When looking through the event viewer there were two items coming up:

Faulting application name: SMSvcHost.exe, version: 4.0.30319.449, time stamp: 0x4d92dcc1
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
Exception code: 0xc0000374
Fault offset: 0x00000000000c40f2
Faulting process id: 0xe58
Faulting application start time: 0x01cd7c9a90d17073
Faulting application path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SMSvcHost.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: f857c65a-e88d-11e1-98cc-50e54932d600

and

Application: SMSvcHost.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 0000000180009E4B


upon looking through the logs to try and pinpoint something i found where the error occurs when the connector tries to talk with the server and it tells me:

EndOpen indicated that the connection attempt failed: (EndpointNotFoundException) Could not connect to net.tcp://"computer-name":6602//Microsoft.WindowsServerSolutions.Common.ProviderFramework.IProviderRegistry. The connection attempt lasted for a time span of 00:00:02.0013084. TCP error code 10061: No connection could be made because the target machine actively refused it 192.168.1.12:6602.  ==> (SocketException) No connection could be made because the target machine actively refused it 192.168.1.12:6602

I have completely uninstalled any antivirus software/firewall software, disabled the windows firewall, opened up the firewall in my soekris device and nothing seems to work.

It seems to be a problem with .net but an sfc /scannow does not solve the issue. ran the .net verification tool from ms and all of the .net platforms checked out okay.
0
jcoltonj32001
Asked:
jcoltonj32001
1 Solution
 
Rob WilliamsCommented:
I assume .NET 4.0 is installed on the client machines?
0
 
Cliff GaliherCommented:
Two suggestions:

First, make sure your SBS server has been *fully* updated. ...don't assume it is either. Actually go into programs and features and view the updates. Specifically, SBS 2011 Essentials UR2 addressed some .Net issues. And UR3 is now out, so I'd go ahead and apply that.

Secondly, download the SBS BPA and see what it reports. It *is* strange that the server is actively refusing connections, even with the .Net issues that have been fixed. The BPA may shed light on what is going on. The current version is 1.4, so make sure you get the BPA fully up-to-date before running a scan as well. The download is 1.0, so you have to install updates to get it current.

-Cliff
0
 
jcoltonj32001Author Commented:
Thank you so much for the comments! Firstly yes .NET 4 is installed and it has been patched with the latest hotfix. I have gone through and made sure that updates were applied and everything looks up to date. I have not applied the UR3 yet so i will try that first thing tomorrow morning when i have access to everything. I will also download the BPA and post any interesting findings. The weird thing is, one computer is able to interact perfectly fine, whereas the other three do not. They are all the exact same computer, exact same hardware, same software, same operating system, same everything, minus the fact that the one that is working had a fresh reload in the past couple months and the others have not. I would just fresh load all of them but it is extremely time consuming to figure out all the licensing and deal with the companies that make the software (it is a CPA firm and they have specialized software). Thanks again for the comments and I will update tomorrow morning.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
jcoltonj32001Author Commented:
SUCCESS!!!

After doing a rather large amount of digging around on one of the clients today I have managed to get the connector to work. I will compose a list of things that I did so that anyone else receiving this trouble will have a good base of information to use.

The problem was .NET on the client machine.



So first and foremost, you MUST make sure that all of the hotfixes are applied. This doesnt mean windows update...there are a couple hotfixes that must be downloaded from microsoft and used only if you are reciving these troubles.

Information is located here: http://support.microsoft.com/kb/2504602

Downloads for the hotfix's are located here: http://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=35626

I installed Windows6.1-KB2504602-v2-x64.msu and NDP40-KB2504602-x64.exe as my architecture is 64 bit.


I also applied this microsoft FixIt, It addresses a WMI issue I found in the Event Viewer. I'm not sure if it is necessary but if you try everything else and still have trouble give it a try.
Here: http://support.microsoft.com/kb/2545227

I then uninstalled the connector software so as to make sure there were no unneccessary calls to the .NET 4.0 framwork, and rebooted. Upon login when the computer started back up I opened Event Viewer and waited for a few minutes. No more ntdll.dll error!! But everything was still not working...after waiting a couple more minutes, sure enough here came the SMSvcHost.exe " .NET" error followed by its twin "Application Error" and the error reporting of course, but this time with a different faulting module, Bfllr.dll. This dll is part of a Bigfoot Networks ethernet driver/application, and after two updates to that application, the error was gone and the program worked! (Also remember I tried a different network card, so it was simply multiple malfunctioning modules in .net)

Also make sure that all the "Windows Server name of service" services are started and running properly.

So to sum everything up, Hotfixes, EventViewer and solve one faulting module at a time.

It seems that any program that uses .NET in any way can cause a faulting module which then will not let your SMSvcHost.exe work period. (Which makes the connector software not work yay!)

Thanks again for the comments!
0
 
jcoltonj32001Author Commented:
This is a summary of most of the information I could find that I used in solving this issue. It took a very large amount of looking on the internet and scouring log files and event viewer stuff to pinpoint exactly what the problem was so I hope that this can help someone to avoid all that work.
0
 
daniel9696Commented:
Our situation was a bit simpler than the above scenario.  To correct ours, which started to act up after we switched our machines from fixed IP addresses to DHCP lookups, we had to go to each workstation's TCP/IP Protocol properties, Advanced Settings, then DNS, then check "Use this connection's DNS suffix in DNS registration" in addition to "Register this connection's addresses in DNS," which was already checked.  Then I toggled the connection disabled to enabled at the workstations and hit refresh on the SBS Dashboard and BANG! There they were.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now