[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Error in ASP.net application after migrating from IIS 6 to IIS 7...

Posted on 2012-08-17
10
Medium Priority
?
726 Views
Last Modified: 2012-08-27
Hello all,

Please be gentle as IIS 7 is not my thing.  We've recently migrated a fully functional website from IIS 6 to IIS 7.  After the migration one function of the application causes the attached error message.  Unfortunately, we had an outside developer write the application and we no longer work with that developer so I don't know much about the code.  I've googled the error message and everything I've found suggests I need to set the trust level to full or that the account being used doesn't have permissions to a file or directory.  I've set the trust level to full and given all the referenced user accounts I can find full control of the website files on the file system.  I loaded Visual Web Developer Express and run the application from that and it runs just fine (I assuming because it's running under my account).  

Any ideas on what I can do to get this running?

Thanks in advance!
0
Comment
Question by:reuniontitle
  • 6
  • 3
10 Comments
 
LVL 26

Expert Comment

by:Alan Warren
ID: 38307594
Hi reuniontitle,
what is the error message?

Alan
0
 

Author Comment

by:reuniontitle
ID: 38308623
Alan,
Sorry, I thought uploaded the screenshot!

I'm out of the office and away from work pc until Monday.

Will post then.
0
 

Author Comment

by:reuniontitle
ID: 38310160
Here's the screenshot of the error.

Thanks in advance...

error screenshot
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
LVL 15

Expert Comment

by:rajeeshmca
ID: 38310717
Hi

try seting the Trustlevel in the web.config file

<trustlevel=“Full“originUrl=“” />

also try the following

you need to have the aspnet user have permission to write to the location on your hard disk you want.  go into Properties / Security settings on file folder and make it writeable.

Regards
Rajeesh
0
 

Author Comment

by:reuniontitle
ID: 38312460
I currently have the following line in my web.config:

 <trustLevel name="Full" policyFile="internal"/>

Should I change it to:

<trustlevel=“Full“originUrl=“” />

Also, can you elaborate on granting permissions to the aspnet user?  There is not an aspnet user account on my 2008 r2 server.

Thanks in advance.
0
 
LVL 15

Expert Comment

by:rajeeshmca
ID: 38314972
0
 

Author Comment

by:reuniontitle
ID: 38316423
Is that valid for Windows Server 2008 R2 web edition?  

There is no aspnet account on my machine.
0
 
LVL 15

Assisted Solution

by:rajeeshmca
rajeeshmca earned 200 total points
ID: 38319872
Hi,

 If ASPNET is not listed, click Add, then click Locations and select your machine name.

Step 1: Open Windows Explorer by right-clicking on the Start menu and selecting Explore.

Step 2:  Navigate to folder on your hard drive, e.g.:

C:\inetpub\wwwroot\


Step 3:  Right-click the folder, select Properties, and then select the Security tab.

Note: if you don't see the Security tab, turn off Simple File Sharing in Tools>>Folder Options.

Step 4:  If the ASPNET user is listed, make sure it has Full permissions, click Apply, and then click OK.

Step 5:  If ASPNET is not listed, click Add, then click Locations and select your machine name.

Step 6:  Select ASPNET, click Add, and then click OK.

Step 7:  Give the user/group Full permissions in addition to the default permissions it is added with, click Apply, and then click OK.
0
 

Accepted Solution

by:
reuniontitle earned 0 total points
ID: 38321639
I've tried to do this, but aspnet is not found on my system.

I found this http://technet.microsoft.com/en-us/library/cc730708%28v=ws.10%29.aspx, and it works for me.

Thanks!
0
 

Author Closing Comment

by:reuniontitle
ID: 38335819
rajeeshmca's suggestion wasn't the fix, as the aspnet account is not part of Windows 2008 R2, but his suggestion lead me to the solution.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
Calculating holidays and working days is a function that is often needed yet it is not one found within the Framework. This article presents one approach to building a working-day calculator for use in .NET.
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question