• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 255
  • Last Modified:

Strange application of group policy in 2008 R2 domain

Simple 2008 R2 domain (albeit running at 2000 level I noticed)

Customer has group policies created and linked into various OUs that match his users. He has some inheretance blocked but at first blush everything looks ok.

One of the group policies is for folder redirection. They previously had folder redirection in another GP (along with some other stuff). That GP has I believe since been changed to no longer point to that location, but to leave the contents in their location. (ie the GP related to folder redirect has been deleted, but there are still other rules left in the GP). I kinda think that might be why were seeing something hinky now.

Heres the strange part
I COPIED a user who isnt getting the new GP, and when I run the wizard that NEW user shows the new and updated GP for folder redirection. Running the wizard on the user I copied does not. Moreover, when I login with that user the folder is redirected properly.

I realize I havent given probably NEAR enough information, but the sheer strangeness that a copied user in the same OU would get different GPresults seems... strange.

Thoughts? Questions? Flames about not giving out enough info (theyre locking the doors, I didnt have time today to do more work)
0
Eric_Price
Asked:
Eric_Price
  • 3
  • 3
3 Solutions
 
btanExec ConsultantCommented:
maybe running gpresult to see what is the policy can give some hints, also at event viewer
http://technet.microsoft.com/en-us/library/cc733160(v=ws.10).aspx
0
 
PeteJThomasCommented:
So what happens if you log on the original user (the one you copied) and run a gpresult /R? I can't remember how the RSoP wizard results display policies which are in scope of the user but not applying for one reason or another...

However I know gpresult from a command prompt definitely clearly shows this and gives a vague reason why the policy isn't applying.

So I'd be interested to see whether the policy is even listed as in scope of the user object and if it was, the reason given for not applying.

So log on as a 'problem' user, run a GPRESULT /R and post the complete results? Or you can run a gpresult /H for a good html report which includes the same info in an easier to read format.

Cheers,

Pete
0
 
Eric_PriceAuthor Commented:
So here are the gpresults. The testuser I created was copied right out of ADU&C from the original amanda user. When I logged in to a PC I had available to me with the testuser, the folder redirection worked. In the original test query in the GP program Amanda consistently failed to show the HP SAN folder redirection policy, though it shows up here now. Im asking the local tech for some additional info to see if our situation has changed...
Test-User.txt
Amanda.txt
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
btanExec ConsultantCommented:
Pls let us know if this need further clarification, looks like a gpo lapse in update
0
 
Eric_PriceAuthor Commented:
Yes this one is still an open issue. Fortunately, it hasnt been a problem for us yet. Ive been out putting away larger fires for a while now, but if you have any ideas on ways to troubleshoot the issue, Id love to hear them.
0
 
btanExec ConsultantCommented:
Didnt see any different in the posted gpresult. We can go for more verbose using /z and /h to put it as html since it is going to be long, not a sure catch but minimally to surface any other errors.

http://technet.microsoft.com/en-us/magazine/ff812646.aspx

Permission seems to be culprit if we try to delete and recreate the new user and sync up with folder redirect.

http://social.technet.microsoft.com/Forums/en/winserverfiles/thread/1682f8a5-4b80-457c-b3f8-3af47ee7984d

So symptoms as before stands? or there is new findings after your IT discussion ...
0
 
Eric_PriceAuthor Commented:
I had to put this thing aside for the time being, but I needed to get some points awarded for your efforts. Thank you all for the assist.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now