• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 899
  • Last Modified:

Exchange 2010 OWA will not allow log in

I just installed a new exchange server.

When browsing to https://myserver/owa it comes up and warns me about the certificate whcih I accept and it then just goes to a blank page.

Where to start to look??
0
Curtis Long
Asked:
Curtis Long
  • 9
  • 8
  • 6
2 Solutions
 
Exchange_GeekCommented:
How about you browse https://localhost/owa from your CAS Server.

Also, disable friendly alerts from your IE so we get to know the exact error.

Do you have any certs installed on your Exchange box?

Regards,
Exchange_Geek
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Check all Microsoft Services are started ?
Can you browse OWA locally on the machine ?
Is the issue with External or Internal ?

- Rancy
0
 
Curtis LongAuthor Commented:
localhost doesnt work either.

Issue is both internal and external.

Just the default cert that is in exchange at start.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Hope the IIS and WWW services along with CAS services are running ?
Also what if you try to browse Default website in IIS ?

- Rancy
0
 
Exchange_GeekCommented:
My best bet is to check is IIS is working or not.
Perform an IISreset and check for results.
Is this box a CAS  and Mailbox?

What happens when you type in https://localhost - do you get IIS 7.0 display?

Regards,
Exchange_Geek
0
 
Curtis LongAuthor Commented:
The website declined to show this webpage
 HTTP 403  
   Most likely causes:
•This website requires you to log in.
 
   What you can try:
     Go back to the previous page.
 
     More information
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Have you checked the services and make sure they are working ?
Also as said you can do IISRESET ?

- Rancy
0
 
Curtis LongAuthor Commented:
https://localhost comes up with:

There is a problem with this website's security certificate.
 
   
 The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.  
  We recommend that you close this webpage and do not continue to this website.  
  Click here to close this webpage.  
  Continue to this website (not recommended).  
     More information


If you arrived at this page by clicking a link, check the website address in the address bar to be sure that it is the address you were expecting.
When going to a website with an address such as https://example.com, try adding the 'www' to the address, https://www.example.com.
If you choose to ignore this error and continue, do not enter private information into the website.

For more information, see "Certificate Errors" in Internet Explorer Help.
 


https://myserver comes up with a blank white page

above you suggest IIS reset.  Explain??  :-)
0
 
Exchange_GeekCommented:
Please uncheck SSL at default web site

http://blogs.msexchange.org/walther/2009/09/11/simplifying-the-outlook-web-app-2010-url/

Regards,
Exchange_Geek
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
RUn the command .... Get-ExchangeCertificates |FL

- Rancy
0
 
Curtis LongAuthor Commented:
reset iis to no avail
ran the command and got this:

[PS] C:\Windows\system32> Get-ExchangeCertificates
The term 'Get-ExchangeCertificates' is not recognized as the name of a cmdlet, function, script file, or operable progr
am. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:26
+  Get-ExchangeCertificates <<<<
    + CategoryInfo          : ObjectNotFound: (Get-ExchangeCertificates:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

[PS] C:\Windows\system32> Get-ExchangeCertificates |FL
0
 
Exchange_GeekCommented:
Can you remove SSL from default web site please and run iisreset?

Regards,
Exchange_Geek
0
 
Curtis LongAuthor Commented:
[PS] C:\Windows\system32> Get-ExchangeCertificates |FL
The term 'Get-ExchangeCertificates' is not recognized as the name of a cmdlet, function, script file, or operable progr
am. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:26
+  Get-ExchangeCertificates <<<<  |FL
    + CategoryInfo          : ObjectNotFound: (Get-ExchangeCertificates:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
0
 
Curtis LongAuthor Commented:
Yes I will.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Sorry its "Get-ExchangeCertificate" and not with S in the end.

- Rancy
0
 
Curtis LongAuthor Commented:
Errors went away but still now log in box.

Am I missing something in IIS??



[PS] C:\Windows\system32> Get-ExchangeCertificate |FL
Creating a new session for implicit remoting of "Get-ExchangeCertificate" command...


AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessR
                     ule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAcc
                     essRule}
CertificateDomains : {WTI-VM-EXCH01, WTI-VM-EXCH01.WillTranInc.local}
HasPrivateKey      : True
IsSelfSigned       : True
Issuer             : CN=WTI-VM-EXCH01
NotAfter           : 8/17/2017 7:42:43 AM
NotBefore          : 8/17/2012 7:42:43 AM
PublicKeySize      : 2048
RootCAType         : None
SerialNumber       : 3923B02F14A8E69143F9391BA88415DE
Services           : IMAP, POP, IIS, SMTP
Status             : Valid
Subject            : CN=WTI-VM-EXCH01
Thumbprint         : D77D491C99536211D513F3B652E9125D3DBE8E92



[PS] C:\Windows\system32>
0
 
Exchange_GeekCommented:
Errors went away but still now log in box.

So, why cannot you log into your box - what does the page state? Does it say Access Denied etc etc

BTW what is your Internal OWA URL?

Regards,
Exchange_Geek
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
You can check the Internal and External OWA URL's in EMC .

- Rancy
0
 
Curtis LongAuthor Commented:
Everything is working ok now.

I pulled up a working exchange server from another location and compared side by side the IIS.  I have missed request monitor and static content.

Thanks ever so much for today!!  :-)
0
 
Exchange_GeekCommented:
Awesome, glad to have helped you :)

Regards,
Exchange_Geek
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Awesome ...... glad to be here :)

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
I meant to Hear :)
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 9
  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now