?
Solved

Switching

Posted on 2012-08-18
2
Medium Priority
?
336 Views
Last Modified: 2012-12-26
I have a 4000 catalyst switch which is configured with a trunk and has a direct fiber run to a room that i am connecting a 3500xl switch too. I can ping the machines in both directions without a problem (from the PCs) but I can not telnet to the 3500 from the PC connected to the 3500 nor can I ping the interfaces of the switches from the ping command with the switches (4000 - 3500) Here is a sample example of the configuration of both switches on each end

4000 Switch
interface GigabitEthernet5/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 1-12,50
 switchport mode trunk

interface Vlan5
 description test
 ip address 10.200.20.1 255.255.255.128
 ip helper-address 10.200.18.10
 ip helper-address 10.200.18.11

VLAN 5    TestTrunk 4000                       active    Gi4/44, Gi6/14, Gi6/20 (PCs at this end)

line con 0
 password 7 014005340B
 login
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password 7 121A0412040F00
 login


3500xl Catalyst Switch

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 1-2,50
 switchport mode trunk

interface Vlan2
 description test
 ip address 10.200.20.2 255.255.255.128
 ip helper-address 10.200.18.10
 ip helper-address 10.200.18.11

interface fastethernet 0/1
switchport access vlan 5
spanning-tree portfast

VLAN 2    TestTrunk 3500                       active    fa/01 (PC at this end)


line con 0
 password 7 014005340B
 login
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password 7 121A0412040F00
 login
0
Comment
Question by:CAEUSA
2 Comments
 
LVL 25

Accepted Solution

by:
Ken Boone earned 2000 total points
ID: 38307786
So the first problem I see is that you have the address space 10.200.20.x on vlan 5 on the 4000 and on vlan 2 on the 3500.  This address space needs to be on the same vlan on both switches.  So 10.200.20.x should be on either vlan 5 on both switches or vlan 2 on both switches.  Each vlan should have its own unique IP address space.

Second problem has to do with your trunk ports between switches.  You have specified the allowed vlans to flow across the trunk.  On the 4000 you are allowing vlans 1-12 and 50, but on the 3500 you are only allowing vlans 1, 2 and 50.  

So if you decide to use vlan 2 on both switches on that address space - no problem, but if you decide to use vlan 5 - then you have a problem, because vlan 5 is not allowed on the trunk on the 3500.  

Ideally the trunk ports on both switches should match as far as the allowed vlans go.

Once you have the ip address space on both switches in the same vlan, then plug a PC on both switches into that SAME vlan, you should not have a problem.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 38307791
I can ping the machines in both directions without a problem
You can ping what from where? What IP address are you pinging and what are you pinging from?

but I can not telnet to the 3500 from the PC connected to the 3500
Once again, what IP address are you telnetting to, what is the IP address of the device you're telnetting from and what port is the device connected to?

nor can I ping the interfaces of the switches from the ping command with the switches
I thought you said that you could ping "in both directions"? What interfaces are you pinging and what are you pinging from?

It would also help to know which interfaces are used to connect the switches together. And I don't see a VLAN2 interface on the 4000. Is there one?
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question