• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 573
  • Last Modified:

Remote Desktop connect to multiple PCs from outside

I would like to connect to multiple pcs within my organization useing RDP from outside.

I have set two PCs up and set one to listen on the default port of 3389 and the other on port 3390.

I have set the router to send port 3389 to the first PC and 3390 to the second.  

I use MSTSC and type in my IP address for the business from my home as follows:

xxx.xx.xxx.xx:3390

It just times out.

If I use the default 3389 port it works fine.

What am I missing??
0
Curtis Long
Asked:
Curtis Long
  • 3
  • 3
  • 2
  • +2
1 Solution
 
Norm DickinsonGuruCommented:
Check your firewall settings for the non-standard port to make sure it is not being blocked.
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Usually, just setting up port forwarding does not allow the port to be used, so you will have to check that on the router firewall.

Your local firewall might or might not block the custom port. Windows Firewall on XP can't be configured to do that, with Vista and above the default setting is to allow all outgoing traffic.
0
 
XaelianCommented:
You have created the portforwarding. But you also need to make sur you allow a connection with those ports.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Curtis LongAuthor Commented:
Some times the simpelist things just flat EVADE me....LOL

Thanks so much!!  :-)
0
 
Curtis LongAuthor Commented:
Oops.....I meant to assign the points to the first responder.

What to do??
0
 
Norm DickinsonGuruCommented:
Qlemo, you have over four million points already - what could you possibly need more for? Why would you want to pre-empt my points, when I am just getting started here (third day today) and have only a few thousand?
0
 
Norm DickinsonGuruCommented:
Thanks, Qlemo. I understand that you have been doing this here for many years and are part of the culture and know all the unwritten rules, I just didn't find your response all that welcoming for a new expert on his third day here. Sometimes an answer like "Check the firewall" is exactly what someone would need, however, as there are several kinds of firewalls and if the author was unsure, they could easily ask for clarification after providing more information. That proved to be the case in this ticket.

I also know this is not the forum for this discussion - my apologies to HDM - is there an "Experts' Lounge" or other area to learn these preferences of the community? I've been in IT since 1979, but only been on this site for less than four days. I have a lot to offer and want to do it right, without creating enemies of the clients or especially the Topic Advisors. :-) Thanks a million - and HDM - sorry to appear like we are bickering during our answers to your question, rest assured we are here to help!
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Question:
Why do you want to make your network publicly accessible and more prone to attack?

Rather than opening up a bunch of ports to allow hackers multiple ways in, why not setup a VPN that allows you connect securely to the network and then RDP to any system on the network.

As another more secure and arguably more convenient solution is to setup an RDP Gateway.

And finally, If you DO make your network more open to Hackers, at least keep things convenient for you - DO NOT change the ports RDP runs on on the Windows clients - use the router and redirect port 3390 to 3389 on the LAN address, and (presumably) 3391 to 3389 on another LAN address.  Otherwise, you have to remember that address on all systems whether you RDP remotely or from the LAN.
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
I agree on leew's points - all of them. But there are routers which do not allow to change the port when using port forwarding. If RDP without VPN is used, change all public ports to something less obvious, e.g. 63000+. Noone will ever try to scan for such ports out of the blue ;-).
Public RDP involves some risk, as there were reported security leaks with the protocol, allowing an unauthorized login with system privileges (!), so you should not make it too easy for intruders.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I know of no business class router that wouldn't support port redirection... And if a business class router isn't being used, it SHOULD be - this IS a business, right?
0
 
Curtis LongAuthor Commented:
Thank you!!

This was all I needed to know to get over my brain dead hump for a minute.  :-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now